Post Go back to editing

LT3748 output voltage drop.. cant figure out why

Evening everyone,

I'm seeing some issues with the LT3748. Here is the schematic of mine:

This is the transformer: https://www.mouser.co.za/ProductDetail/Wurth-Elektronik/750310617?qs=%252BUQ4csG8Rscr4kcgwycPjw==

At the output of this I have the following two circuits connected:

If I have either the 5V or 10V LDO connected to the lt3748, the output of the flyback converter is fine.. I get 12V at the output of the flyback and either 5V or 10V at the output of the LDO.

When I have both of these LDO's on the board, the flybacks output voltage drops to about 2V. The gate previously had a switching frequency with a relative high frequency, now that both are connected and the output voltage has dropped, the pulse train to the MOSFETs gate has a very low frequency.

Does anyone know what could be causing this? I thought maybe over current but I cant imagine it being that. I even swapped the 8m ohm resistor with a 2m ohm to double check and nothing changed. The LDO's aren't driving anything( their outputs aren't connected to anything).

What am I doing wrong?



formatting
[edited by: EngJunkie at 11:21 PM (GMT -5) on 7 Nov 2021]
Parents Reply
  • Based on the typical applications on the datasheet, 12W output is possible. The problem could be from the layout. Try to follow the layout guidelines on the datasheet and the PCB files of the demo boards. If you can, try to get hold of the DC1557A demo board as it is the closest to your application. It is good to have a working board to better understand how the circuit works then try to modify it from there.

Children
No Data