LTM4650A Can not work normally

hello:

There are two pieces of LTM4650A-1 on my circuit, input 12V, output 0.85V. The two circuits are the same, and one is not working properly.
Sometimes the power is suddenly lost, and sometimes it cannot be started.
When unable to start or power down, the various states are as follows
Vout:0.99V or 1.5V
Good:0V
INTVCC:5V
RUN:3.8V
VFB:0V

Parents
  • +1
    •  Analog Employees 
    on Dec 9, 2020 7:47 PM

    Hello,

    It is possible that VFB is causing the problem. INTVCC=5V means that the module and its internal control circuitry are powered on. When working properly, VFB should always be regulated to 0.6V. If VFB=0V, the module will lose power or have issues starting up as you observed. Please check if there is anything that may cause FB pin and the FB resistors to short to GND in your circuit. 

    Another suggestion I have is to change the 1k resistor on MODE/PLLIN pin to 0ohm resistor to make sure all channels are in continuous mode.

    Thank you!

    Liyao

Reply
  • +1
    •  Analog Employees 
    on Dec 9, 2020 7:47 PM

    Hello,

    It is possible that VFB is causing the problem. INTVCC=5V means that the module and its internal control circuitry are powered on. When working properly, VFB should always be regulated to 0.6V. If VFB=0V, the module will lose power or have issues starting up as you observed. Please check if there is anything that may cause FB pin and the FB resistors to short to GND in your circuit. 

    Another suggestion I have is to change the 1k resistor on MODE/PLLIN pin to 0ohm resistor to make sure all channels are in continuous mode.

    Thank you!

    Liyao

Children