ADP2291 dont indicate for charging the battery

Hi Folks,

I am Using the ADP2291 . I have two circuits parallel which they are Isolated with BAT1000 to support the system .

 I am using Sanyo Battery 18650(4.1~3.7 V ,2800mA).

I used the application circuit with HERMAL PROTECTION, figure 25 on data sheet .

The only difference is RS value which is 0.15 ohm to increase the charging current at the beginning .

Single circuit ,(100% Discharged Batt)Power up the circuit will draw 1500 mA as expected . after 10 minutes Led goes to off mode. Input current draw by source is reaching to 400 ma after 15 min .  I expect to charging continue for at least 2 hours with approximately 1300 mA  to full charge the battery .

input voltage is 5.04 v---4.74 V is the voltage before on RS In-Pin  ,100 mV drops cross the RS .  VCE = 0.922 ---VB =3.74V

V ADJ = 2.145v

V CHG = 3.69  ,V between the Resistor and LED is 3.69 V ...No current drawn .

Note : I placed the NTC close to the Pin of the Batt . Temp of the battery is not exceed the 95 degree F (Measured )

 Why the circuit goes to shutdown status very quick ?

Picture is attached .

Thanks for Help

Ash

Parents
  • Hong,

    1) Increase the input voltage to 12V. Is the problem still there? It is not possible ,My input is solid +5.0 V ,If even does work ,I cant increase the Vin.
    2) will it work if you use single ADP2291 charger to battery? NO.Those Circuits are isolated and does work individual. I did test for single board all time to make sure the concept works ,But still I have problem .
    3) Try to use a normal resister instead of NTC resister as the impedance may vary a lot with different beta and type. Already, I removed the NTC totally and make the pin float .similar to the simple circuit ! No luck

    Thanks

    Ash

Reply
  • Hong,

    1) Increase the input voltage to 12V. Is the problem still there? It is not possible ,My input is solid +5.0 V ,If even does work ,I cant increase the Vin.
    2) will it work if you use single ADP2291 charger to battery? NO.Those Circuits are isolated and does work individual. I did test for single board all time to make sure the concept works ,But still I have problem .
    3) Try to use a normal resister instead of NTC resister as the impedance may vary a lot with different beta and type. Already, I removed the NTC totally and make the pin float .similar to the simple circuit ! No luck

    Thanks

    Ash

Children
No Data