LTC6810-1 iso-SPI Communication Problem

Hi,

I have a probelm with isoSPI communication in LTC6810-1 Battery Monitoring IC. I have a proper communcation with the 1st IC using SPI, but the communication between this 1st Slave and 2nd one is through isoSPI, they are connected in series. Its not working. Please help in resolving this issue. 

Thank you with Kind Regards,

Anup Pravin1st Board with SPI.pdf2nd Slave Board with isoSPI.pdf

Parents
  • 0
    •  Analog Employees 
    on Oct 22, 2019 7:54 AM

    Hi Anup,

    It seems ICMP and IBIAS connections have been reversed in your schematic. please refer to following image 

    Also, I would suggest you to have these values ( 3k, 1k ) same across all devices, including 6820. Please note: These values are 1k on all demo boards. 

    You might want to increase value of current limiting resistor of Vreg LED. 

    Regards

  • Hey, Perfect :) I was struggling this for a very long time. I couldn't figure out this small mistake. It worked with 1k itself. But as per your suggestion, I will use RB1-3K and RB2-1K. Is that right?

  • 0
    •  Analog Employees 
    on Oct 23, 2019 9:17 AM in reply to AnupPravin

    You can use RB1-3K and RB2-1K, just make sure that it is same throughout the chain. 

  • It worked. Here is my new design. I have ttwo files one for the slave module and another for iso spi communication ltc6820 with the master. Please have a look at it, and confirm.

    1. In the slave module document, I have only one transformer because I will be having other slave ICs on the same PCB.

    PDFPDF

    And I have some more questions.

    1. Regarding combining ICs with part number LTC6810HG-1 (which can withstand 125 degrees C temp) and LTC6810IG-1 (which can withstand 85 degrees C temp). Can I use a combination of these ICs in series? Even though I am limiting my temp limit to 60 degrees C, right now I have both. Does it affect my software design? What do you prefer?

    2. About the connector and cable for iso-SPI communication. Between the slaves, and between the master and slave? its less than 1 meter between any of these boards.  Should I choose something specific wit respect to connector and cables?

    Please Replay as soon as possible. Thank you.

    With Kind Regards,

    Anup

Reply
  • It worked. Here is my new design. I have ttwo files one for the slave module and another for iso spi communication ltc6820 with the master. Please have a look at it, and confirm.

    1. In the slave module document, I have only one transformer because I will be having other slave ICs on the same PCB.

    PDFPDF

    And I have some more questions.

    1. Regarding combining ICs with part number LTC6810HG-1 (which can withstand 125 degrees C temp) and LTC6810IG-1 (which can withstand 85 degrees C temp). Can I use a combination of these ICs in series? Even though I am limiting my temp limit to 60 degrees C, right now I have both. Does it affect my software design? What do you prefer?

    2. About the connector and cable for iso-SPI communication. Between the slaves, and between the master and slave? its less than 1 meter between any of these boards.  Should I choose something specific wit respect to connector and cables?

    Please Replay as soon as possible. Thank you.

    With Kind Regards,

    Anup

Children