Post Go back to editing

LTC4162-L charging issue


Please help me as I'm stuck!

I use LTC4162-L to charge a lithium battery and it works great!. I had a few prototype boards and every time I solder it myself. I've been having issues with the latest boards and the design and layout is the same as previous ones! It gives an output but it doesn't charge the battery. I tried resoldering a few boards multiple times but still haven't fixed it. Sometimes charging turns on but it turns off next time I plug in.

I took the good working board and non charging board and swapped all the components one by one and still good working board worked meaning that there wasn't a component issue.

I tried measuring the voltages around the IC to spot the difference and I noticed that pin 11 is 1.01V for a good working board and pin 11 oscillates from 0V to 2.4V slowly maybe once per second. What does it mean? 

What are the other reasons for this IC not to charge? I use it standalone design without a micro so I can't debug it. Maybe its a thermal issue, I'm not sure.

I resoldered it multiple times now and its the same issue. The output still works even when I plug in the battery. Its just doesn't charge. I had a few times charging while testing so its not like it doesn't work all the time. Also the battery I'm using is low so it should charge. I also tried leaving it for like half an hour.