LTC4015 CHEM0 & CHEM1 issue

Hi Zack.

I am using the LTC4015 with plain satisfaction. More then 1000 boards are working and stable.

Solved/clarified all the doubts about this and that.

LTC4015 is working with 12 cells Lead_acid battery and in "hardware" mode (CHEM0 and CHEM1 are opened).

I use the telemetry to monitor the system and everything is fine and as expected.

The +5V for CHEM0:1 and CELLS0:2 are derived from the 24Voutput followed by a LM317 + LT1763-5 (the LTC4015 is a part of a system where the LM317 and LT1763-5 are available for other purposes. So, instead of use Int_Vcc I use a separated +5V to reduce the LTC4015 consumption). This chain works well because in the main project CELLS0:2 are detected rightly.

I am charging the batteries with 3.6A and the Isystem is over 27A. No EMI/RFI (passed with plane votes all the CE tests ... here in Italy).

_______________________________________________________________________________________________________________________

I have a strange behavior with a new setup. I want now to manage the current charge and I change CHEM0:1 from Z Z to L H respectively.

At the startup of the firmware, after 3 seconds, when I have initialized other i2C chips as usual, I try to access the LTC4015 by a i2c_start(0xD0) and the LTC4015 i2C doesn't reply.

Seems that when I pull CHEM0:1 I block the LTC4015 i2C interface.

If I desolder the jumpers everything works fine. Tried on 5 prototypes. The story is always the same:

if I pull CHEM0 and CHEM1 the LTC4015 becomes inaccessibile by i2C interface.

Any suggestion?

Thanks