Post Go back to editing

LTC6813 Discharge LEDs not turning on - S pin voltages not changing when sending discharge commands?

Category: Software
Product Number: LTC6813-1

(copied from another thread i made, same problem setup) Hello, I am designing a BMS using the LTC6813. I built a custom board to balance 18 cells and communicate using isoSPI. Currently, I am debugging the board using the DC2792B isoSPI adapter plugged into the Linduino and I am running the test code from the LTSketchbook titled DC2350AB. To emulate a battery pack, I have connected 1000 Ohm resistors in series and connect the top and bottom to 60V power supply.

I was able to measure the cells and run tests through isoSPI, however, I went to try turning on discharge, which I expected to verify functionality by seeing the discharge LEDs turn on, except they did not, and I tried measuring the voltage at the gate of the PMOSFETs to see if it changed when the command is sent, and it did not. 

I initially thought the LEDs were laid backwards, but upon testing, they are in the proper direction. 

Does discharging with the resistor setup not work? I am wondering if I should switch to actual batteries to test this, but I am not sure I fully understand how the discharge features work in the software. I tried some of the setting the DCCBits to "true" on line 179 as seen in this screenshot and then try to discharge the corresponding cells, however the LEDs did not light up. Can someone explain the functionality of the DCCBits? When the LTC6813_set_discharge function is called, is the DCCBit for that cell being set to 1?

I think, upon reading the datasheet, I have a theory as to why it is not working: I left the DTEN pin floating, and it seems if it is tied to VREG, the switches will stay on for the programmed time (4 minutes, in the default case for the LTSketchbook code). If the DTEN pin is left floating, could this be causing the issue? I included screenshots of the LTC6813 schematic setup as well as the schematic for the external balancing MOSFETs.