ADIsimPE fails to update

Hi!

I was using version 8.1 of ADIsimPE, until now that it detects there is a version is 8.2 and refuses to make simulations.

But the installer I downloaded from https://sdk.analog.com/pmp/pmp.aspx?file=PMP1300 is still 8.1 and no longer works, even uninstalling my present installation.

Do I have to wait for ADI to upload the 8.2 updater or am I downloading from a wrong place?

I already asked this to ADI Americas Technical Support and they pointed me to this forum

Thank you!