How to drive MOSFET switches in a cascaded hybrid modular multilevel converter using a half-bridge driver "IR2103S"

Hi guys
I am trying to drive the MOSFET switches in a cascaded hybrid modular multi-level converter as shown in Fig. 1. Fig. 2 is used here to simplify the circuit and to present the problem (let's focus on Fig.2 instead of Fig.1). The type of the MOSFET used is "IRF530N". Each cell is integrated with half-bridge (called a sub-module) while each pack of sub-modules is integrated with full-bridge (called a module). Each module is connected to the next module (cascaded). The type of the Half-bridge driver used is "IR2103S". A single IR2103S is used to drive each half-bridge while two of IR2103S are used to drive each full-bridge as shown in Fig. 3 and Fig. 4, respectively. Note that in Proteus software, I have used IR2104S instead of IR2103S (both of them are able to achieve the same function). For each half-bridge (except the last half-bridge used), the wire between the COM pin of "IR2103S" and the source pin of the low-side MOSFET switch is lifted as shown in Fig. 5. Cell voltage=3.4V, Rg=47ohm, a capacitor with 22uf/25V, and DC/DC isolated is used for each half-bridge.

The circuit is operating correctly when I am using only one module (only one full-bridge is used) (i am able to measure the positive and the negative output voltage across the H-bridge).
The problem appears when using two modules in a cascade way (see Fig.5). Connecting the load is necessary in this case to complete the circuit. I noted that I can measure the positive output voltage across the two H-bridges correctly (9.7 to 10.1V) while I can't measure the correct negative output voltage (I got -8.42 V).

I have tested the circuit in the lab and by Proteus software and I got the same results. The Proteus file is attached.

I have two questions:
1) Am I able to use the half-bridge driver (IR2103S) to drive the MOSFETs or I should use an individual driver (such as TLP351H) for each MOSFET?
2) if I can use IR2103S, is there anybody who can help me to figure out where is my mistake and how to connect the circuit correctly?

Thanks in advance

Fig. 1Fig. 2Fig. 3 Fig. 5