Post Go back to editing

Unable to perform a firmware update with Wavetool for the EVAL-ADPDUCZ

Category: Software
Product Number: ADPDUCZ
Software Version: 5.10.0


I've recently bought an EVAL-ADPDUCZ as well as an EVAL-ADPD188BIZ-S2 and I want to use Wavetool to print the measure of the sensor but the firware upgrade is not working. I've followed the quick start guide and I have done so far :

- Connected the battery

- Installed the FTDI device drivers

- Installed the current 5.10 version of Wavetool

- Installed DfuSe USB device firmware upgrade

- Connected the two usb port to my PC

- Tried to connect the the dev-bord with Wavetool (won't let me because of the firmware version)

- Change the mode to device firmware update with the boot0 button (a new peripheral appears in the device manager)

- Tried and failed to upgrade firmware with the following error message : "the application was unable to start correctly (0xc000007b)"

By following the solution to other discussions on the forum concerning the same issue, I've tried so far to:

- Disconnecting/connecting the battery

- Moving to a lower version of Wavetool (version 3.5.0 gives the same results)

- Running Wavetool as admin

- Changing the default driver for the bootloader found by windows (being "STM32 BOOTLOADER") by manually installing the driver named "STM Device in DFU Mode" (the windows 10 version as there is not a windows 11 version) from the Wavetool 5.10 folder, the Wavetool 3.5 folder and the STM DfuSe folder. All of them produce the same result.

I do not know why I am unable to upgrade the firmware on this board and I don't have another EVAL-ADPDUCZ to try this on.

Thanks in advance,