Post Go back to editing

ADRV9002 ZCU102 Calibration Error

Category: Software
Product Number: ADRV9002
Software Version: Vivado 2023.1

Hi Team,



             I'm using hdl_2022_r2 and no_OS_2022_r2 for ZCU102_ADRV9002 project creation. At the time of initialization, I am getting calibration error. I'm using custom ADRV9002 with device clock of 100MHz. I am stuck at Calibration state. 

Here I'm attaching the no-OS prints:

Hello
DEBUG: RX1 enabled
DEBUG: TX1 enabled
DEBUG: RX2 enabled
DEBUG: TX2 enabled
DEBUG: pos: 15, Chan1:1BE5F7, Chan2:1BE5F7[ERROR]: Error number 3 (0x00000003), Recovery action -101.In file ../src/noos/drivers/rf-transceiver/navassa/devices/adrv9001/public/src/adi_adrv9001_arm.c, in function adi_adrv9001_arm_CmdStatus_Wait, in line 646, variable name device.Error message ArmCmdStatusWait() failed due to thrown ARM error. Is device in correct state for calling command?.
[ERROR]: Error number 13314 (0x00003402), Recovery action -2.In file ../src/noos/drivers/rf-transceiver/navassa/devices/adrv9001/private/src/adrv9001_arm.c, in function adrv9001_ArmCmdErrorHandler, in line 2822, variable name mailboxErrCode.Error message Error occurred during an Init Calibration. Check that no signal is being applied to the Rx ports. Check that correct external LOs are applied, and synchronized, where appropriate.
[ERROR]: Error number 13314 (0x00003402), Recovery action -2.In file ../src/noos/drivers/rf-transceiver/navassa/devices/adrv9001/public/src/adi_adrv9001_cals.c, in function adi_adrv9001_cals_InitCals_Run, in line 107, variable name NULL.Error message Error occurred during an Init Calibration. Check that no signal is being applied to the Rx ports. Check that correct external LOs are applied, and synchronized, where appropriate.
adrv9002_setup, 997: failed with "Error occurred during an Init Calibration. Check that no signal is being applied to the Rx ports. Check that correct external LOs are applied, and synchronized, where appropriate" (13314)



Thanks in advance
Goli Ganesh

Parents
  • calibration error occurs becuse

    1. voltage levles are not stable for adrv9002

    2.cloclk signal doesn't meet voltage level of LVDS standrards of adrv9002

    3. system is not in correct state ie adrv should be in standby state 

    4. clock mentioned in code should match clock given to adrv9002

    my suspision is on point 4 becuse you are using diffrent clock(100MHz) than gnerally used clock ie 38.4MHz please check Navassa_CMOS_profile.h that  "deviceClock_kHz\": 38400, change it to"deviceClock_kHz\": 100000, to match your 100 MHz freqency

Reply
  • calibration error occurs becuse

    1. voltage levles are not stable for adrv9002

    2.cloclk signal doesn't meet voltage level of LVDS standrards of adrv9002

    3. system is not in correct state ie adrv should be in standby state 

    4. clock mentioned in code should match clock given to adrv9002

    my suspision is on point 4 becuse you are using diffrent clock(100MHz) than gnerally used clock ie 38.4MHz please check Navassa_CMOS_profile.h that  "deviceClock_kHz\": 38400, change it to"deviceClock_kHz\": 100000, to match your 100 MHz freqency

Children
No Data