Post Go back to editing

adrv9002 TX2 has no transmitting spectrum

Category: Software
Product Number: ADRV9002
Software Version: no-osMaster ADRV9002 Rev 12.0, Firmware 0.20.0.8 API version: 48.49.2 and Firmware 0.21.0.8 API version: 67.1.1

Hello,all

I ported the ADRV9002 driver using the no-OS program. The configuration file used the built-in NAVASSA_LVDS_Profiler. h and the clock was set to 38.4MHz in LVDS mode.

The initialization and correction procedures have passed, RX1 and RX2 can also see the signals of I/Q channels through ILA, but using the AXI-DMA transmitter module, TX1 and TX2 can see the I/Q data sent to adrv9001 IPcore, valid signal and enable signal are also normal. The upper layer RFenable is all turned on. Currently, only the transmitted monophonic spectrum can be seen from the TX1 RF port, with the maximum power around -20dbm. However, TX2 basically can't see anything, and the signal is only about -75dBm. In the process of initialization correction, both TX1 and TX2 have seen a large spectrum scan. It can be concluded that it is not necessarily related to my hardware design, but should be a problem of software configuration. Now I suspect that the gain parameter of TX2 may be given as 0, but I can't find where to set it, or there are other problems. Can you give me guidance?
I'm also curious what role TxAttenTable.h plays in the program, and does it play any role other than initializing and correcting the configuration

Another problem is about the transmission module of AXI-DMA. Every time I power on and start the board card, after downloading the PL program, I run the vitis upper-layer software, only the data given by the DMA sending side can be seen for the first time. When I run the vitis software running program again, the DMA module will not send data, and the problem can only be solved by power failure and restart. Contrast receiving AXI-DMA module does not have this problem, this is why?

Kind Regards!

--Fantish

Top Replies

    •  Analog Employees 
    Feb 24, 2023 in reply to fantish +1 suggested

    Hi  

    Sorry for such a big response delay,

    1. What carrier are you pairing up the adrv9002 with ?

    And how are you testing ? Loopback cables between Tx and Rx ? Or you use antennas ?

    In any case, if…