ADRV9002 through RCAL error

Hi,

we are trying to use ADRV9002 through IIOScope , but while system boot we are getting "ADC RCAL error"  and ADRV9001 not detecting. (boot error attached)

Also we tried using no-OS driver and same error we were getting. it is failing in Digital_init function , in that at bootstate  checking. 

previously ADRV9002 was working and we were getting read value = 0x11 from ADRV9001_ADDR_ARM_CMD_STATUS_8 (#define ADRV9001_ADDR_ARM_CMD_STATUS_8 0x010E)

But now after RCAL error we are getting read value= 0xD0 from ADRV9001_ADDR_ARM_CMD_STATUS_8.

also adding that, from some previous thread we check voltage from RBIAS across resistor R624 which is coming 0V

request you to kindly check and guide us some solution.

boot error log "

6.127110] adrv9002 spi0.0: [ERROR]: Error number 13 (0x0000000d), Recovery action -101.In file drivers/iio/adc/navassa/devices/adrv9001/public/src/adi_adrv9001_arm.c, in function adi_adrv9001_arm_StartStatus_Check, in line 161, variable name NULL.Error message ADC RCAL error.
[ 6.151797] adrv9002 spi0.0: adrv9002_digital_init, 2299: failed with "ADC RCAL error" (13)
[ 9.867580] adrv9002 spi0.0: [ERROR]: Error number 13 (0x0000000d), Recovery action -101.In file drivers/iio/adc/navassa/devices/adrv9001/public/src/adi_adrv9001_arm.c, in function adi_adrv9001_arm_StartStatus_Check, in line 161, variable name NULL.Error message ADC RCAL error.
[ 9.892264] adrv9002 spi0.0: adrv9002_digital_init, 2299: failed with "ADC RCAL error" (13)
[ 9.900661] cf_axi_adc: probe of ff230000.axi-adrv9002-rx-lpc failed with error -14"

thanks & regards,

shivshankar Thatti