ADXL355 Latch-up condition

Dear ADI support,

 

We have been using ADXL355BEZ in our condition monitoring (vibration transducer) products for a while, we’ve sold about 1000+ of them now.

 

We recently discovered that some of them fail strangely – they report a near-zero vibration (the AC part) - after experiencing a period of over-range high-frequency vibration. We initially suspects our firmware might have bugs, but after some research, we are now quite confident that it’s caused by the defects of ADXL355.

 

We know that ADXL355 has over-range protection mechanism when experiencing excessive accelerations. When activated, the output will be pulled towards midscale in order to protect itself. This is acceptable. But in some rare cases, this condition will persist even after power is re-cycled. The only way to bring the device back to normal is to tap it (or knock it, if you will) with a screwdriver or something.

 

While in latch-up condition, the ADXL355’s output consist of a fixed DC acceleration (in our two cases, it’s around -5g in x-axis. (we didn’t investigate other axis). On top of that, there’s also a high-frequency (around 1.6Khz) AC content, measured around 3.9g rms.

 

As I said previously, the condition is only cleared when external shock is applied. We did not try issuing self-test command. We’ll investigate more if you need more information. I’ll keep you up to date.

Parents Reply Children
  • For a select group of sensors, we can definitively confirm that they were not subjected to an acceleration higher than the rated specification; both during production and at the customer site. In these controlled tests, the sensors were mounted rigidly to an asset at a customer site and operated correctly for an extended period of time. The acceleration levels experienced by the sensor can be confirmed by reviewing time-waveform acceleration trend data which clearly indicates operation at a safe level for a few months followed by the failure mode reappearing randomly. To your point regarding the spec, I have tested a few dozen sensors which have been subjected to levels of acceleration much higher than the specification rating, and the failure mode these exhibit is different from the ones I see in the former failure mode. The former failure mode can be 'turned' on/off by exposing the sensor to a high transient shock which is not true of the latter.

  • The question is, if subjected to exceesive acceleration, then what?  You didn't mention in your specs that this could cause "latch-up" or "damage".

    This issue is far from over.