Problem encoding analogue audio with ADAV801

Hi,

I am attempting to add ADAV801 codec support to my 2.6.35 kernel to be
used with an ARM processor. I can see that there is a mainlined
adav80x.c driver that appears at kernel version 3.1, I have had a
quick look at back-porting the driver but this looks as though it
could get quite messy.

However, I did come across an older ADAV801 driver which looks a lot
simpler, but I cannot find it in previous mainlined kernel versions,
http://www.spinics.net/lists/alsa-devel/msg36465.html, so I thought I
would use this as a basis for my own driver.

From what I understand from the datasheet and the way the older driver
has configured the registers on the ADAV801 I should be able to see
some data on the record outputs, however this is not the case. Could
anyone confirm whether or not this driver dated August 2010 is OK to
use? Or perhaps some advice on areas to look at that may be preventing
the CODEC from manipulating and outputting the digital conversion.

Best regards

Parents
  • 0
    •  Analog Employees 
    on Aug 2, 2018 4:27 PM
    This question has been assumed as answered either offline via email or with a multi-part answer. This question has now been closed out. If you have an inquiry related to this topic please post a new question in the applicable product forum.

    Thank you,
    EZ Admin
Reply
  • 0
    •  Analog Employees 
    on Aug 2, 2018 4:27 PM
    This question has been assumed as answered either offline via email or with a multi-part answer. This question has now been closed out. If you have an inquiry related to this topic please post a new question in the applicable product forum.

    Thank you,
    EZ Admin
Children
No Data