AD9523 and AD9680 kernal compatiblity

Are the driver AD9523 and AD9680 available in https://wiki.analog.com/resources/eval/user-guides/ad-fmcdaq2-ebz compatible with linux kernel version 4.14?

Thanks