ADuM6403CRWZ- 10Mhz spi problem

hey'

i use ADuM6403CRWZ to isolate spi signals, its work good for 4Mhz spi rate but for 10 Mhz its miss 1 bit. when i remove the isolator its work good for 10 Mhz.

this version of the chip need to be good for 25Mbps why its not good for 10 Mhz spi?

there is a replacement for this chip to work with 10 Mhz ?

sahar

Top Replies

    •  Analog Employees 
    Mar 12, 2021 +2 verified

    Hi Sahar, 

    AN-1478 goes into specific application details for isolated SPI. It shows some possible solutions as well. 

    The problem you are having is due to the propagation delay of the isolator and the nature…

Parents
  • +1
    •  Analog Employees 
    on Mar 12, 2021 1:21 PM

    Hi Sahar, 

    AN-1478 goes into specific application details for isolated SPI. It shows some possible solutions as well. 

    The problem you are having is due to the propagation delay of the isolator and the nature of SPI. In SPI the signals only have a half clock cycle (from the master's perspective) to propagate through the bus. Its the round trip through the isolator limiting the SPI clock. An isolator with lower propagation delay, like the ADuM6421A, is quick enough to enable a >10Mhz SPI clock.  

    Regards,

    Jason  

Reply
  • +1
    •  Analog Employees 
    on Mar 12, 2021 1:21 PM

    Hi Sahar, 

    AN-1478 goes into specific application details for isolated SPI. It shows some possible solutions as well. 

    The problem you are having is due to the propagation delay of the isolator and the nature of SPI. In SPI the signals only have a half clock cycle (from the master's perspective) to propagate through the bus. Its the round trip through the isolator limiting the SPI clock. An isolator with lower propagation delay, like the ADuM6421A, is quick enough to enable a >10Mhz SPI clock.  

    Regards,

    Jason  

Children
No Data