LTM9100 Constant Current with load voltage monitoring failure

Hi

I'm using LTM9100 for monitoring current and voltage generated by Constant current source as well as for OV protection , the application diagram i have used for reference is below.

Can i use below circuitry for Constant current operation by connecting load parallel to 330uF capacitor ?

The schematic implemented on my board is attached as pdf below.

schematic _LTM9100_mine

Note : R212 , R224, R161 in schematic attached is not mounted on board.

Issues Faced are mentioned below

Case I :

Electronic load of 7 ohm CR mode is connected across PIN 1 and PIN 4 of connector J7. Constant current of 6A is given at net +0v-96V. At electronic load, voltage reading of 7*6= approx 42V is observed but LTM9100 reads 3FF for both ADIN and Sense registers.

Case II :

When load is not present , LTM9100 reads 000 for both ADIN and Sense registers. 

Case III: (Most critical issue)

Electronic load of 1 ohm CR mode is connected across PIN 1 and PIN 4 of connector J7. Constant current of 0.2A is set to appear at net +0v-96V.

Note : Constant current source use low side current sensing feedback mechanism to maintain set current.

In this case, at electronic load, current reading of 6.5A  is observed but LTM9100 reads 3FF for both ADIN and Sense registers. It appears LTM9100 (in 1 ohm load case) is not switching on gate for 0.2V load voltage (due to constant current of 0.2A through 1 ohm load).  Is there any such drawback for this IC.

Please let me know the steps need to be taken to fix above issues .



Attached files
[edited by: Bivin at 5:19 AM (GMT 0) on 12 Jan 2019]