Post Go back to editing

LTC4040 , removing battery

Hi all

I have a small (?) problem
I want battery cell is completely disconnected when my product is travelling (plane)
So I first put a bistable relay on pin 23 (BAT) to cell.
This works perfectly.

So where is the problem ?

It's about some shocks.
In rare cases, if my product as a violent shock, relay can cut the power too

So I decided to put a mosfet instead of relay.
I also add a voltage comparator so CHGOFF become high when celle is reaching 4V1 (this work)

But the problem is, even CHGOFF is on high level, charge continues slowly (in one or two days, it will reach about 4V4)

So my question is: how to get charge really stopping (perhaps I could join to CHGOFF NTC pin but did it really change anything ?)

Thanks for help

Parents
  • Hello,

    You should not need to manually detect the termination voltage and force the charger off. The charger will terminate at this voltage naturally if you select the 4.1V termination voltage.

    In fact, if there's no hysteresis on the comparator, I wonder if it gets into a state where it toggles charging on/off repeatedly.

    The charger will not charge to 4.4V unless something else is wrong. Have you added any other path on your circuit that may result in over-charging? The first step is to identify where the current is coming from.

    Regards,
    Zack

  • Hello

    Thanks for your answer.

    I added a comparator because, as soon I replaced relay by mosfet, I noticed cell value was (very slowly) increasing at 4V4 (remember with a relay cell value never exceed 4V1). The comparator output became high exactly at 4V1 cell value.

    I also take a look at oscilloscope signal: when mosfet disconnect cell, I can see short pulses. So I thinks this is the problem: it seem internally there is a permanent cell control and this affect LTC4040 to cell connection if I add a mosfet.

    Regards

  • You mentioned you saw sparks with the relay connected. I wonder if the circuit was damaged which might explain the overcharging.

    Otherwise, if you added the FET between the battery and the battery voltage sense, that might also account for an error in charge voltage. Both the battery power path and the sense connection should be on the same side of the FET.

    Do you have a schematic to send?

    Regards,
    Zack

  • 1) No , I didn't saw "sparks" with relay. I wrote I saw regular pulses with an oscilloscope probe but with mosfet replacement.
    Relay (bistable) is only used to completely shut off my system.
    Charging with relay, the system will works perfectly so final cell maximum value is 4V1.
    Notice there is a low current consumption (most of time less than 100mA, maximum < 1A ).

    2) So, why did I tried to change relay by a mosfet ? this because, rarely, significant shock can affect relay mechanical position and so, if the system is running it can be stopped and will never re-start (it will need to be connected to another system to do so). As the system is used for security control and doesn't need human control, it's not acceptable.

    3) "that might also account for an error in charge voltage" . I think this must be the problem. 

    [img]zupimages.net/.../img]

    [img]zupimages.net/.../img]

  • What is VCHARGE_P1? Maybe some wake-up charge path?

    Make sure that is not supplying more than the battery's full charge voltage (really it should be around ~2.5V). Otherwise it seems like it could overcharge the battery.

Reply Children