Can’t debbug the example IOS_Realtime_BLIP2 on the blip2 evaluation board

Hello,

I try to run in debug mode the program example IOS_Realtime_BLIP2 on the evaluation board ADZS-BF707-BLIP2. But the debug session goes in a an unknown state.

There is no problem when i run the program from the flash memory. But their in no error in the console, the program just go in an unknown state.

It run well with the GUI program from ADI.

I follow the instructions in the ReleaseNote of the BSP to edit the custom board package ADZS-BF707-BLIP2-proc.xml.

I run the other program example Power_On_Self_Test well in debug mode.

In step by step mode, the program will go in an unknown state after i execute the instruction highlighted in the second screenshot.

At this point, the program is in unknown state. I pause the debug session. The noticeable things at this point  is in the disassembly. Some instructions are marked at *illegal opcode*.

My OS is  windows 10 and i use:

CrossCore Embedded System 2.5.1

Evaluation board ADZS-BF707-BLIP2 Rev 2.0, BOM Rev 2.2

Debugger ICE-1000

Some of you ever experience this problem?

It’s weird because i use all default example from Analog Device, and one example run well.

Thanks in advance for your answers.

Pierre