Post Go back to editing

SigmaStudio for SHARC

Hi,

As for SigmaStudio for SHARC, after the schematic was compiled and the program binary code(Hex doucment) was downloaded to the 21489 EZ-kit’s flash from address 0x00,but it does not work, I want to know what’s wrong with it ,whether I also need to  download Parameter code to flash?and anything else I need to download?

Best regards,

Taoshaofeng

Parents
  • Hi Taoshaofeng,

    Please follow the below steps.

    1. Compile the schematic and export the system files. While exporting, you will be asked to provide an export name. Let's assume that the name provided is "test". Also assume that the name of the IC in the schematic is "IC 1". Then you will find a file "test_IC_1.h" along with the exported files.
    2. Copy all the exported files to the "utility" folder.
    3. Next, open cygwin and go to the "utility" folder.
    4. Issue the command make SWC "EXPORT_FILE=test_IC_1"

    Please let us know the error message if the above steps are not working for you.

    Regards,

    John

Reply
  • Hi Taoshaofeng,

    Please follow the below steps.

    1. Compile the schematic and export the system files. While exporting, you will be asked to provide an export name. Let's assume that the name provided is "test". Also assume that the name of the IC in the schematic is "IC 1". Then you will find a file "test_IC_1.h" along with the exported files.
    2. Copy all the exported files to the "utility" folder.
    3. Next, open cygwin and go to the "utility" folder.
    4. Issue the command make SWC "EXPORT_FILE=test_IC_1"

    Please let us know the error message if the above steps are not working for you.

    Regards,

    John

Children
No Data