Post Go back to editing

ADSP-SC584 ARM core hangs

Category: Software

I am having some strange behaviour withthe ARM core on the ADSP-SC584. I have the issue that the core hangs at random moments. When this happens the debugger can no longer get any usefull information out of the core. If i read out the registers i get garbage data and same for the memory.

See screenshots.

However, the SHARC cores are still working as expecteced an i can still read out the the memory with the debugger through these cores. I have verified that there is no stack or heap corruption for the arm core by reading out the memory that way. I have also verified that the DDR ram is working properly by running a stress test for the ram without any issues.

I would expect that if there is a any exception which would cause the core to hang, the prorcessor would trigger the exception handlers. But this is not the case in this situation. I have tried to manually reproduce this behaviour by writing any buggy code i could think of, but this always triggers the exception handlers as expected, and never ends up in a state where the core just hangs.

Any idea what could be the possible reason for this behaviour?

I am using CCES 2.10.1 with the ADSP-SC584 on a custom board.

Parents
  • Hi,

    Could you please let us know whether you facing this issue in this specific project? If so, please let us know which application/example that you are trying to run from Sigmastudio for SHARC.

    Which version of Sigmastudio for SHARC that you are using?

    Did you tried in any other machine? If not, please try and let us know whether you are facing issue there.

    Is it possible for you to use latest version of CCES 2.11.1 and try running the example?

    Awaiting for your reply.

    Regards,
    Nishanthi.V

  • We are running an application which was built starting from the DemoUc example included in sigmastudio. Currently we are using Sigmastudio for SHARC 4.7.

    I have not tried it on another machine as i believe the license that i am using is node locked.

    Can i update to 2.11.1 without license or compatibility problems with SS for sharc 4.7?

  • Hi Robrecht,

    From our records, we seen that you have active subscription for your license, so you can install and use CCES 2.11.1 without any issue. The previous license file will apply automatically for this version of CCES.

    You can download and install CCES 2.11.1 from the below link.
    download.analog.com/.../ADI_CrossCoreEmbeddedStudio-Rel2.11.1.exe

    If possible, please try change the workspace in CCES 2.10.1 and import your project and run.

    Please try these at your end and let us know the result.

    Regards,
    Nishanthi.V



  • I have tried importing the project, but i am running in to the issue that certain include paths related to sigmastudio cannot be found even though they are defined and correct.

  • Hi,

    We are checking internally now and will get back to you as soon as possible.



    Regards,
    Nishanthi V

  • Hi Rob,

    From your screenshot, we understand that you are receiving only warning in 'include' location. If so, you can just ignore it.

    Also, to aviod the runtime issue in ARM in latest CCES 2.11.1, please go to the memory size in the follwing file,C:\Analog Devices\SoftwareModules\SigmaStudioForSHARC-SH-Rel4.7.0\Target\Examples\Framework\Include\adi_ss_fw_config.h and change the memory size to #define ADI_SS_CONTROL_FW_ARM_MEMORY           (10912U)

    If you are facing any issue, then please let us know.

    Coming to your first issue ARM hangs, could you please first try exporting the schematic in Sigmastudio for your application and try include it in the CCES project in 2.10.1 itself.

    The default SigmaStudio schematic source files generated with “Release” built DXE. So if you want to use for “Debug” built DXE, you need to regenerate schematic source files again with “Debug” built DXE. Please refer “AE_42_SS4G_QuickStartGuide.pdf” section “7.2 Running the DemoUc application with a custom schematic” for generating schematic source files.

    You may also refer "A. Utility for formatting Exported data from SigmaStudio" section in "AE_42_SS4G_QuickStartGuide.pdf" document in
    "C:\Analog Devices\SoftwareModules\SigmaStudioForSHARC-SH-Rel4.5.0\Docs" folder.

    Also,please refer the below linked thread which might helpful.
    ez.analog.com/.../how-are-some-files-created-in-the-ucdemo

    Regards,
    Nishanthi.V


  • Hi,

    These are not just warnings, these are errors. I am unable to compile my project because CCES gives an error that it cannot find the header files in that specific location. Event though they are there. The screenshot is there to illustarte the issue.

    Why exactly should i increase the size of the memory used in the "adi_ss_fw_config.h"? I have this file generated by SS, so i would assume that the size in this file would be correct for the project?

    Th DXE's of our SS project are currently built in release mode. I am already using the utility as documented to generate the source files. However, i am not having any issues with the SHARC cores. When the processor hangs, it is just the ARM core. The SAHRC cores are still running fine.

    Regards,

    Robrecht

  • Hi,

    Are you using default demo example and example schematic what is provided in the package? which example application?
    did you modify the default framework?
    did you clear the CCES workspace and tried? 

    "Why exactly should i increase the size of the memory used in the "adi_ss_fw_config.h"? I have this file generated by SS, so i would assume that the size in this file would be correct for the project?"
    The SPORT driver used from the CCES. The memory allocated based on 2.10.1 is lesser than what it required in CCES 2.11.0 or later. So, you need to adjust the increase in memory for running the framework.

    Thanks.

Reply Children
No Data