CCES can not generate the correct XML file

Hi

CCES can not generate the correct XML file after compilation. why? The contents of the XML file are as follows:

<?xml version="1.0" standalone="no"?>
<?xml-stylesheet type="text/xsl" href="file:///D:/Analog Devices/CrossCore Embedded Studio 2.2.0/System/linker_log.xsl"?>
<DOCUMENT gen_time='Fri Nov 16 16:17:01 2018
'>
<MSG id='00985708' mid='li3201' type='Informational' suppressed=''>
<TEXT><![CDATA[Successfully eliminated 14 bytes in dynamic 'p0'
]]></TEXT>
<EXTENDED_INFO><![CDATA[Eliminated object (_adi_initComponents, ._adi_initComponents.end) of size 14 bytes from '.\system\adi_initialize.doj(seg_swco)'
]]></EXTENDED_INFO>
</MSG>
</DOCUMENT>

  • Can generate DXE files correctly,The compilation results are as follows:

    'Building target: Mixer_Invert_12in10out.dxe'
    'Invoking: CrossCore SHARC Linker'
    cc21k.exe -proc ADSP-21489 -si-revision any -TD:/WorkingFolder/WorkItems_2017/SigmaModule/HmAlgSrc/Mixer_Invert_12in14out/Mixer-Invert.ldf -no-mem -LC:/Analog\ Devices/SoftwareModules/SigmaStudioForSHARC-SH-Rel2.1.0/Target/ExtModules/Common/BasicOps/Lib -flags-link -MDDEBUG,-MDCORE0 -add-debug-libpaths -flags-link -nomemcheck, -flags-link -gis,., -flags-link basicops_214xx.dlb -o Mixer_Invert_12in10out.dxe ./system/adi_initialize.doj ./src/Mixer-Invert.doj ../Mixer-Invert.ldf -flags-link -od,.\.
    'Finished building target: Mixer_Invert_12in10out.dxe'
    ' '
    make --no-print-directory post-build
    elf2dyn -o MixerInvert_12in10out.dyn -e _BPROCESS_MixerInvertAlgo -a ss4sh_param=2 Mixer_Invert_12in10out.dxe
    Exporting: _BPROCESS_MixerInvertAlgo

  • Hi,

    Please let us know following details,

    May I know which version of CCES and SigmaStudio for SHARC package you are using?

    which xml file you are observing the issue?

    whether you are building custom application or example?

    Thanks.