NFS boot failed

Hi,

I´m trying to get a embedded board design of ours to boot from NFS. It is based on a blackfin BF527. The board itself is functional, but I´d like it to boot from NFS to increase development velocity. I have followed all of the instructions found here: uclinux-dist:nfs [Analog Devices Open Source| Mixed-signal and Digital Signal Processing ICs], but booting still fails with the following error:

TCP cubic registered
NET: Registered protocol family 17
lib80211: common routines for IEEE802.11 drivers
Registering the dns_resolver key type
IP-Config: Complete:
     device=eth0, addr=10.42.0.251, mask=255.255.255.0, gw=10.42.0.1,
     host=AIP102BFA, domain=, nis-domain=(none),
     bootserver=10.42.0.1, rootserver=10.42.0.1, rootpath=
Warning: unable to open an initial console.
Waiting 5sec before mounting root device...
usb 1-1: new high speed USB device number 2 using musb-hdrc
usb 1-1: New USB device found, idVendor=0846, idProduct=9030
usb 1-1: New USB device strings: Mfr=16, Product=32, SerialNumber=48
usb 1-1: Product: WNA1100
usb 1-1: Manufacturer: NETGEAR WNA
usb 1-1: SerialNumber: 12345
PHY: 0:00 - Link is Up - 100/Full
Root-NFS: nfsroot=/home/alberink/tftp/rootfs,tcp,nfsvers=3,retry=3
VFS: Unable to mount root fs via NFS, trying floppy.
VFS: Cannot open root device "nfs" or unknown-block(2,0)
Please append a correct "root=" boot option; here are the available partitions:
1f00             256 mtdblock0  (driver?)
1f01            5888 mtdblock1  (driver?)
1f02            2048 mtdblock2  (driver?)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)


Listening in with wireshark, I can see that no NFS packets are exchanged anywhere. All required drivers for NFS and such are compiled into the kernel, not as modules.


The relevant u-boot commands:

nfsargs=set bootargs root=/dev/nfs rw nfsroot=${serverip}:${rootpath},tcp,nfsvers=3,retry=3 rootdelay=5 nfsrootdebug console=ttyBF0,115200 earlyprintk=serial,uart0,115200
nfsboot=tftp ${loadaddr} ${nfsfile};run nfsargs;run addip;bootm
nfsfile=vmImage


Please advice, as this is starting to drive me nuts.



Parents Reply Children
No Data