2009-07-20 07:19:48     sata & dm9000 driver continue!

2009-07-20 07:19:48     sata & dm9000 driver continue!

billy zhou (UNITED STATES)

Message: 77719   

my old thread pls see:

https://blackfin.uclinux.org/gf/project/uclinux-dist/forum/?_forum_action=ForumMessageBrowse&thread_id=35177&action=ForumBrowse&forum_id=39

and:

blackfin.uclinux.org/gf/project/uclinux-dist/forum/?_forum_action=ForumMessageBrowse&thread_id=34807&action=ForumBrowse&forum_id=39

Now I use the 2009r1 with the old dm9000, to download into my old ide board, it work normally.

ftp several G bytes data,  only with a little error.

but reboot get error, and can't work!

pls see attach files:

ftp error( tranform success).txt

boot info.txt

QuoteReplyEditDelete

2009-07-20 21:21:36     Re: sata & dm9000 driver continue!

billy zhou (UNITED STATES)

Message: 77776   

now I do follow the info, do this before mount /dev/sda /usr/local/

echo 0 > /proc/sys/kernel/hung_task_timeout_secs

as a result:

it pause in

dma_alloc_init: dma_page @ 0x0161a000 - 256 pages at 0x01f00000                

/proc/sys/vm/pagecache_ratio: can't create                                     

mount: mounting /dev/hda on /usr/local/ failed: No such file or directory      

mount: mounting /dev/hda1 on /usr/local/ failed: No such file or directory

but when I use my old 2007r1 image, it boot normally , and mount fast!

so I think it maybe something wrong with the mount command to the sata driver!

QuoteReplyEditDelete

2009-07-20 21:41:46     Re: sata & dm9000 driver continue!

billy zhou (UNITED STATES)

Message: 77777   

after a success mount for using the old image,

the new image can mount normally now.

QuoteReplyEditDelete

2009-07-20 23:21:33     Re: sata & dm9000 driver continue!

Sonic Zhang (CHINA)

Message: 77785   

there is no /dev/hda in 2008 and 2009 release.

Please mout /dev/sda instead.

QuoteReplyEditDelete

2009-07-21 19:56:01     Re: sata & dm9000 driver continue!

billy zhou (UNITED STATES)

Message: 77793   

already use these three to avoid mismount

mount /dev/hda /usr/local

mount /dev/hda1 /usr/local

mount /dev/sda /usr/local

QuoteReplyEditDelete

2009-07-21 22:19:04     Re: sata & dm9000 driver continue!

Sonic Zhang (CHINA)

Message: 77799   

No. you should use:

mount /dev/sda1 /mnt

mount /dev/sda2 /mnt

......

QuoteReplyEditDelete

2009-07-22 00:49:28     Re: sata & dm9000 driver continue!

billy zhou (UNITED STATES)

Message: 77806   

I fdisk hdd by entire , so I use mount /dev/sda /usr/local

QuoteReplyEditDelete

2009-07-22 00:53:12     Re: sata & dm9000 driver continue!

billy zhou (UNITED STATES)

Message: 77807   

that is not the problem!

fdisk use sda1 get the same result.

pls get into the problem, and help us to solve the problem.

thanks a lot!

QuoteReplyEditDelete

2009-07-22 01:56:00     Re: sata & dm9000 driver continue!

Sonic Zhang (CHINA)

Message: 77812   

Please run following command in your console:

root:/> dd conv=fsync if=/dev/zero of=/usr/local/test bs=1M count=1000

then

root:/> reboot

If this works well, that means the problem in is dm9000 hardware or software. Since we don't have dm9000 and its driver is not maintianed by us, you'd better ask dm9000 maintainer directly.

QuoteReplyEditDelete

2009-07-22 02:00:45     Re: sata & dm9000 driver continue!

Sonic Zhang (CHINA)

Message: 77813   

In addition, "page allocation failure" means there is not enough free memory in the system. It looks like ftpd consumes too many memory.

QuoteReplyEditDelete

2009-07-22 23:01:09     Re: sata & dm9000 driver continue!

Barry Song (CHINA)

Message: 77896   

Even though FTP maybe has problem, it should not destory the disk partition. It seems the harddisk is still  not too reliable.

Did you set proper wait states for the async memory bank that the IDE board connects?

At my site, the setting is

Blackfin Processor Options  --->

    EBIU_AMBCTL Control  --->

        (0x7BB0) Bank 0

        (0x7BB0) Bank 1

        (0x7BB0) Bank 2

        (0xFFC3) Bank 3

If I used the default setting, the harddisk access is not reliable too.

Can you check it?

-Barry

QuoteReplyEditDelete

2009-07-22 23:34:18     Re: sata & dm9000 driver continue!

Barry Song (CHINA)

Message: 77899   

And also please check the bus frequence:

x lqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqk x

  x x    [ ] Default bootloader kernel arguments                             x x

  x x    (0x1000) Kernel load address for booting                            x x

  x x        *** Clock/PLL Setup ***                                         x x

  x x    (25000000) Frequency of the crystal on the board in Hz              x x

  x x    [*] Re-program Clocks while Kernel boots?                           x x

  x x    [ ]   Bypass PLL (NEW)                                              x x

  x x    [ ]     Half Clock In (NEW)                                         x x

  x x    (20)    VCO Multiplier (NEW)                                        x x

  x x          Core Clock Divider (1)  --->                                  x x

  x x    (5)   System Clock Divider (NEW)                                    x x

  x x          DDR/SDRAM Timing (Calculate Timings (EXPERIMENTAL))  --->     x x

  x x        *** Kernel Timer/Scheduler ***                                  x x

  x x        Timer frequency (250 HZ)  --->                                  x x

Changing "(20)    VCO Multiplier (NEW) "    to 16 or less value can help the derease the frequence. Sometimes, high freq cause reliable problems too, depending on your board layout.

You can use bonnie++ tools in my uclinux-dist to make sure the stability of your hardware.

According your reply in

2009-07-15 02:22:36     Re: 2009r1-rc1 error with dm9000 driver

billy zhou (UNITED STATES)

Message ID: 77276    

1. how can I use rcp? can you give me a example

2. I cp data in sata with the serial terminal command, and it works normally

but after cp hundreds M data, it can't reboot...

boot info as below

boot-sata.txt

Your harddisk access has some problems in fact. Then the FTP problems maybe are caused by it too.

  • Created
Was this helpful?

Before You Switch


Switching languages will make ADI Explorer unavailable. Resume your session by switching back to English and reopening ADI Explorer.