Cannot connect to EZ-KIT Lite after programming Flash.

I loaded the code into flash on BF537 EZ-Kit Lite and run it successfully. However, since doing so I cannot connect to the target in VisualDSP++. How I can get my EZ-Kit Lite to return to its original state so that I can connect?

  • 0
    •  Analog Employees 
    on May 11, 2009 9:43 AM

    CraigG wrote:

    I loaded the code into flash on BF537 EZ-Kit Lite and run it successfully. However, since doing so I cannot connect to the target in VisualDSP++. How I can get my EZ-Kit Lite to return to its original state so that I can connect?


    There are circumstances under which the Application running from Flash on the EZ-KIT Lite can render the target incommunicable. Please check the BMODE settings on the EZ-Kit Lite, and set it to boot from another source. This will prevent the application in Flash from running, and should allow you to establish communication with the target from the IDDE. You can find the EZ-KIT Lite Evaluation System Manual under 'Help'->'Contents'->'Manuals'->'Hardware Manuals'->'EZ-KIT Lite Evaluation Systems'->'Blackfin'. This manual details the specific switch settings for the EZ-KIT, and covers the various BMODE switch settings.

    Once you have connected to the target, you can re-flash it with the Power On Self Test example located in "...\Blackfin\Examples\ADSP-BF537 EZ-Kit Lite\Power_On_Self_Test\", and set the boot mode back to 1. Alternatively, you can use the Flash Programmer Utility to simply erase the flash, so that it cannot be booted from.

  • 0
    •  Analog Employees 
    on Apr 29, 2019 10:45 AM
    This question has been closed by the EZ team and is assumed answered.