Post Go back to editing

ADZS-HPUSB-ICE: Error 0x8004801e – USB Data Count Error


I have the error 0x8004801e - USB Data Count Error opning a session to a Blackfin BF518.

If I run the ICE test it works fine without any error.

If I use the ADZS-HPUSB-ICE with other boards with BF518 it works fine.

Before it stopped working I was debugging a test project based on the "FPGA_memory_test" in order to communicate with our FPGA board.

this is the code I run:

*pEBIU_AMGCTL = 0x00F3; //AMBEN[0] and CLKOUT

#define FPGA_START 0x20000000 // start address of FPGA (uses /AMS0)
#define FPGA_SIZE 0x00000200 //4096 bits

volatile unsigned int *pDst;

int wrBank0 = 0x1234, rdBank0;

pDst = (unsigned int *)FPGA_START;

*pDst = wrBank0;


rdBank0 = *pDst;

if (rdBank0 != wrBank0)
bError = 0;

Running it in debug it stopped at "*pDst = wrBank0" and the emulator lost connection.

After that I was not able to connect to the target anymore with the error above.

Is it possible that I damaged something running that code?

How can I restore JTAG communication?

Thank you and best regards