Post Go back to editing

CPLB error when calling adi_gpio_RegisterCallback()

I am calling following adi function in CCES 2.10.0 for a BF706 project.

adi_gpio_RegisterCallback(ADI_GPIO_PIN_INTERRUPT_2, ADI_GPIO_PIN_5,Handler_drdy, (void*)0);

and when running it breaks with following error at highlighted line 536.

A non-recoverable error or exception has occurred.
Description: a data COLB miss has occurred without a corresponding CPLB entry.
General Type: RunTimeError
Specific Type: DCPLBMissWithoutReplacement

I checked/unchecked CPL box in  startup config and both lead to same break above. What's going on?

Parents
  • Hello,

    The _cplb_miss_without_replacement is called by the default exception handler when a CPLB Miss exception has occurred, and the default handler is unable to find a CPLB entry in the table which corresponds to the address which caused the miss.

    We recommend you to check your cache protection options. Double click the "System.svc", navigate to the 'Startup Code/LDF' tab. In the 'Startup Code' tab there are options for Instruction and Data Cache - enable or disable these as required.

    The other possible cause of the CPLB miss without replacement in your program could be the use of an invalid address, or when there is a NULL pointer.

    Please refer the example code for interrupt using push button from BSP package.

    Please install the Board support package of BF707 for the example.

    download.analog.com/.../ADI_ADSP-BF707_EZ-Board-Rel1.0.1.exe

    After installation example available in the below path:
    Installation path: "Analog Devices\ADSP-BF707_EZ-Board-Rel1.0.1\BF707_EZ-Board\Blackfin\Examples\services\gpio\Button_LED_GPIO"

    For more details please refer the below linked Ezone threads which might help you resolve your issue:
    ez.analog.com/.../202507

    Best Regards,
    Santhakumari.K

  • Hello, I've already double checked the system.svc and the snapshot is in the question if you read again. Also the pointer is not NULL if you see the code it faults when it's trying to assign Pins. But previous assignmnments were OK. Problem still persists.

  • Hi,

    Please refer the attached example code for interrupt using push button and check whether it is running correctly in your processor or not and please let us know that which board that you are using, BF 706 EZ-KIT (or) Custom board?

    Awaiting for your reply.

    Best Regards,
    Santhakumari.K

    0728.Button_LED_GPIO.zip

  • Thanks Santha. It is a custom board. Problem doesn't occur anymore but we haven't made any changes, not sure what was the source but we moved on.

Reply Children
No Data