ADAU1701 - on-chip and External DAC problem

Hi All,

I have a problem with a new application with ADAU1701 DSP.

I would use both DSP DACs and an external CODEC, but after some tests I have the audio output on the ADAU1701 DACs or on the external CODEC DACs, but not both.

In my system I have an AK4620B CODEC as audio input ADCs and low noise stereo DACs, and I use also ADAU DAC2 and DAC3.

I have a 24.576MHz crystal and I used an internal fs=96kHz  (I used your faq instruction for PLL setting), the clock output is buffered and the DSP works as master of I2S comunication (MP4 and 5 connected with MP10 and 11 each).

I have test, with a simple audio path (attached TestInternalDac.jpg) that internal DAC works properly.

Only when I check the Master Mode checkbox in the Hardware Configuration windows the output signal disappeared.

Changing the outputs to I2S data I could see the audio signal on CODEC.

So...could I work with both outputs type or is not allowed?

Or have I make something wrong?

Thanks and best Regard.

attachments.zip
Parents
  • Hi Deca,

    You can use the on-board DACs and serial ports at the same time. You just have to route signals to them in the DSP program. Here's a graphic showing how each analog and digital data channel is assigned in SigmaStudio.

    It looks like in your project, you have not connected the DIGx output cells in your project. Just add those, and you should be fine!

    An example project is attached for reference.

Reply
  • Hi Deca,

    You can use the on-board DACs and serial ports at the same time. You just have to route signals to them in the DSP program. Here's a graphic showing how each analog and digital data channel is assigned in SigmaStudio.

    It looks like in your project, you have not connected the DIGx output cells in your project. Just add those, and you should be fine!

    An example project is attached for reference.

Children
No Data