ADAU1466 Serial Port 2 Configuration

I am looking for assistance with setting up Serial Input Port 2 as an I2S input using SigmaStudio 3.17.  I have created a project with a Input block with channels 32-33 selected.  This connects to a two channel volume control and then to two outputs.  The project link, compiles and downloads without problem and the volume control is working.  However, instead of Serial Port 2 accepting I2S signals as inputs, it is sending out Bclk and LRclk clock signals.  Looking at the ADAU1466 data sheet, pins 65-67 (Serial Port 2 pins) are bidirectional and must be configured.  Obviously, the project I have desinged with SigmaStudio is not properly configuring these pins. 

Parents
  • Dave,

    Thank you for the reply to my question.  I can see from the screens that you included and your description of what I need to do that you understand my question and know the answer.  Frustratingly, however, I have searched all over SigmaStudio 3.17 and I cannot find the "hardware register settings tab under the Serial Port sub-tab" that you reference.  I apologize for my ignorance, but after checking everywhere on the screen, the Toolbox, and after checking the options and settings for the cell in my design "Input1" (which has channel 32-33), I cannot find what you are talking about.  I also went back through everything I could find in the toolbox to see if there is such a thing as "Serial Input Port 2", but all I can find as a possible "input" in the toolbox is "I/O", "Input", "Sdata 32-39", "Input".  I am using this as the input in my schematic (as you can see from the project I attached).   Resigned to my embarrassment when shown the "answer", I must "give up" and ask for further explanation as to how you locate the items you reference. Lol.

    Thank you!

    Patrick

Reply
  • Dave,

    Thank you for the reply to my question.  I can see from the screens that you included and your description of what I need to do that you understand my question and know the answer.  Frustratingly, however, I have searched all over SigmaStudio 3.17 and I cannot find the "hardware register settings tab under the Serial Port sub-tab" that you reference.  I apologize for my ignorance, but after checking everywhere on the screen, the Toolbox, and after checking the options and settings for the cell in my design "Input1" (which has channel 32-33), I cannot find what you are talking about.  I also went back through everything I could find in the toolbox to see if there is such a thing as "Serial Input Port 2", but all I can find as a possible "input" in the toolbox is "I/O", "Input", "Sdata 32-39", "Input".  I am using this as the input in my schematic (as you can see from the project I attached).   Resigned to my embarrassment when shown the "answer", I must "give up" and ask for further explanation as to how you locate the items you reference. Lol.

    Thank you!

    Patrick

Children
No Data