ADAU1466 running ?

Bought the EVAL-1466Z.. Installed SigmaStudio 4.6.
First thing i noticed: the docuenatation for the board (Rev. 0) does not match the actual board, but the almost identical EVAL-1452-documentation seems to be uptodate...
The board was powered and connected to the USBi, an audio signal was given to the analog input 1, and an amplifier was connected to analog output 1.
Then i did exactly what the documentation advised: Started a new project, dragged the ADAU1466 and the USBi icons to the hardware sheet and connected them.
Then went to schematic, dragged inputs and outputs to it and connected them (0/1).
I compiled, no errors, and downloaded it to the board. The status bar got green and it said "Active: Downloaded".
But no sound from the outputs (inputs had some music on them...).
I changed the inputs against the sinus oscillator and connected it to the outputs, activated the oscillator, compiled and downloaded it, but still no sound.
Tried every possible output, so sound.
What bothers me: On the hardware configuration page, looking at the ADAU1466 register controls, the core seems to be not running (reading the core status says "core not running", when the "start core" command is given, the core goes green but after the next read of the status its getting red again (statusbar stays green all the time...).
(Registers 0xF402 and 0xF405 are read as 0xFFFF)
The documentation of the evalboard says, that everything is prepared for the board to run without special initialization of registers (all on default...).
The clock control seems to be ok (all green), but the panic register shows all read after a read.

What am i doing wrong, what to initialize to have a tranparent flow from analog input to output or from the internal sinus oscillator to the analog output (to start with something "simple").
Is there any sample for the ADAU1466 evalboard that i could try ?

I thought, it could be an easy start into the world of DSPs...

Thank you

 

  • What i forgot to say...
    Measured all accessible points on the board, power is ok, the crystal oscillating but there is absolutely no other clock or datatransfer between adc/dac an the DSP visible. So that makes we more thinking that the core is not working.
    Reading the registers of the ADAU1466 seems to give just 0x7FFF or 0xFFFF.
    I will not believe that the board arrived damaged here, it was bought from digikey and the box was sealed ok.

  • A new observation:
    Problem could be the USBi...
    When the USB is attached to the computer the signals cclk and cdata (pins 9 and 10 of the ribbon connector) are initialy 3.3V / high.
    But as soon as there is "talking" to the evalboard (e.g. doing a read of registers in SigmaStudio) the signals cclk and cdata switch to 1.5V statically (tristate ?) and toggle between 0 and 3.3V when data is transferred.
    Looks odd for me. Is that ok or is there something wrong ?

    •  Analog Employees 
    on May 28, 2021 5:00 PM in reply to i2e

    Hello i2e,

    This has to be something simple. I am glad you figured out the user guide issue. Yes, the eval board was updated and the same design was used for both the 1452 and the 1466. I was able to write the user guide for the 1452 Rev B but we had an issue with updating the 1466 user guide. Hopefully that is taken care of soon. 

    I have attached a project that we setup for testing this board in production. I modified it for two things. The first is to have a choice of an oscillator as a signal source to send out of the codec. The second is a DC cell and Readback which tests if the SPI comms are working. There may be an issue such that the SPI is not working. SigmaStudio has no way to know if the DSP actually picked up the program because SPI does not have any ACKs. So click the readback READ button and see if it reads the "1" from the DC cell. If not then that is the issue, SPI is not working so then we need to trouble shoot that. 

    Dave T

    ADAU1452REVB Eval Board Test Project with OSC.zip

  • Dave,


    you won't believe it...
    ...but the ribboncable at the USBi modul has shorts between pins 9 and 10 (sclk and sdata) and pins 11 and 12 (gnd and /clatch1).
    So there was really never any proper communication between SigmaStudio and the evalboard. I will fix that on monday and try again.
    So i guess that the USBi modul was not tested properly.
    Fortunately my USBi has additional series resistors between the ribbon and the cypress (not shown in AN-1006, because of that i measuerd a level of 1.5V on both pins), so the short between sclk and sdata should not have damaged the cypress. Hopefully the short between gnd and /clatch1 did no harm...

    •  Analog Employees 
    on May 28, 2021 7:52 PM in reply to i2e

    Hello i2e,

    The Cypress chip has built in I2C but the SPI functionality is done using the GPIO of the cypress part. So yes, it will tri-state when it is not active. 

    Yes, we added those series resistors a long time ago to prevent failures when there might be a problem with the customer boards or eval boards. 

    Once the ribbon is fixed I think it will function properly. Let me know how it goes. 

    Dave T