ADSP21992 boot load mode.

Hi,

I have ADSP21992 connected to serial eeprom of 64kbits. The boot mode setting for this will be as follows

BMODE2 = 1

BMODE1 = 0

BMODE0 = 1

After I reset the processor manually, I do not see any signal on SCK, MISO or MOSI pins of SPI.

The reset procedure looks ok because when I program using ICE, the manual reset works properly.

Could anyone tell me what else I should check?

Thanks,

Porter.

  • 0
    •  Analog Employees 
    on Sep 25, 2012 5:39 PM

    Hi Porter,

    Are you able to see the CLKOUT signal toggling at expected frequency ?  Please also refer to the following statement in the data sheet (page 14).

    "During power-up the RESET line must be activated for long enough to allow the DSP core’s internal clock to stabilize. The power-up sequence is defined as the total time required for the crystal oscillator to stabilize after a valid VDD is applied to the processor and for the internal phase-locked loop (PLL) to lock onto the specific crystal frequency. A minimum of 512 cycles will ensure that the PLL has locked (this does not include the crystal oscillator start-up time). The RESET input contains some hysteresis. If an RC circuit is used to generate the RESET signal, the circuit should use an

    external Schmitt trigger."

    Please make sure that this is taken care of this as well.

    Thanks,

    Mitesh

  • 0
    •  Analog Employees 
    on Aug 2, 2018 4:39 PM
    This question has been assumed as answered either offline via email or with a multi-part answer. This question has now been closed out. If you have an inquiry related to this topic please post a new question in the applicable product forum.

    Thank you,
    EZ Admin