asm21k Error

I have old code being compiled with the asm21k.exe assembler that was working fine until about a week ago and it started giving me the following error:

Exiting due to signal SIGSEGV

General Protection Fault at eip=000011d54

eax=fffd0000 ebx=00000000 ecx=000002ab edx=fffd0000 esi=00001000 edi=00000009

ebp=00065cf8 esp=00065ce8 cs=01a7 ds=01af es=01af fs=017f gs=01bf ss01af

Call from traceback EIPs:

0x00011d54

0x00011cd1

0x00011e42

0x0000e1c4

0x0000c05e

0x00003911

0x000032c0

0x000015da

0x0000104b

Error(s) found when Pre-Processing

I haven't touched the code. It seems to be a Windows issue because it will run when I reboot in Safe Mode, but not otherwise. I manually disabled all of the Windows start up stuff manually and couldn't get it working.

Has anybody seen anything like this? I inherited this piece of code, so I don't know much about what it's trying to do.

Thanks for the help in advance.


Parents
  • It is running on Windows XP. The code and assembler came as part of MRI scanner control software we have running in our lab. The solution we got from the software provider is to reformat the computer, but I would rather not do that. But if it is unsupported, that may be our only solution.

    Thanks for the help.

Reply
  • It is running on Windows XP. The code and assembler came as part of MRI scanner control software we have running in our lab. The solution we got from the software provider is to reformat the computer, but I would rather not do that. But if it is unsupported, that may be our only solution.

    Thanks for the help.

Children
No Data