Post Go back to editing

Connecting with XMC4400 processor through ADALM-UARTJTAG

Hi all,

First of all, forgive me for not being an electronics engineer - however I hope you'll be able to help me. A couple of years ago I had a company design a pcb for a project of mine. I had the possibility to change some of the settings by hooking it up to a secondary board which connects to my pc and sending simple text commands. I cuold for example read the settings by sending the command 'paraget' en changing a setting by sending 'paraset 1 5' which changed the first setting to value 5.

All worked fine until the secondary board got lost during a move, and the company who designed the board no longer exists. Now I'm trying my best to find the right components, and I feel that I'm almost there but not quite yet.

So, here's what I have to work with:

- I have on my board an 8 pin 'debug connector', where I mapped the pins to the processor pins (the processor is a 64 pin XMC4400 F64F256 AB

I managed to find the following connections:

  1. VDDP
  2. P1.5
  3. Not Connected
  4. Not Connected
  5. PORST
  6. VSS0/VSS
  7. TCK
  8. TMS

- When I power the board, there is 3,3V between VVDP (+) and VSS (-) and between PORST (+) and VSS (-)

- I imagined I could use the Analog Devices ADALM-UARTJTAG board to communicate with my board, but I think the pin layouts are not the same. From the datasheet I found:

I think I should rewire the cable between the 2 boards, but other than connecting TMS to TMS and TCK to TCK I am lost at how to correctly wire the rest.

Thanks for the help!