Post Go back to editing

lwip problem-ping not working /BF527

Hi.

We have a hardware with ethernet lan 8700i  with PHYADD = 1f and with full duplex. we changed Dev->phyadd = 0x1f and full duplex = true in liblan8700BF527

using following program. after run program shows link established. but ping and connect is not happening. in our hardware we are using BF527 processor.

Target is able to send ARP packets.We use the program below which works fine in adsp bf527 ez kit.

C:\Program Files\Analog Devices\VisualDSP 5.0\Blackfin\Examples\ADSP-BF527 EZ-KIT Lite\LAN\Host\FILESERVER

can u plz suggest us the problem why ping is not happening.We tried TCPIPTRACE,INETD programs also ,and ping fails but link is established.

We have reserved bank3 (LAST BANK)flash for FPGA.

Thanks...........

Parents
  • What does RX_FRAG & RX_FRLEN indicate? I think the default size of a PING packet is 74 bytes from a Windows PC. You may also catch the ICMP packets via a RAW socket with the buffer considering the IP packet, ICMP packet and echo data.

    // create RAW socket
    rawSocket = socket(AF_INET, SOCK_RAW, IP_PROTO_ICMP);

    // catch the echo request
    sock_ret = recvfrom(socket,         
               &echo_request_info,         
               sizeof(echo_request_info), 
               0,       
               NULL,     
               NULL);

    Regards

    Prasanth.

Reply
  • What does RX_FRAG & RX_FRLEN indicate? I think the default size of a PING packet is 74 bytes from a Windows PC. You may also catch the ICMP packets via a RAW socket with the buffer considering the IP packet, ICMP packet and echo data.

    // create RAW socket
    rawSocket = socket(AF_INET, SOCK_RAW, IP_PROTO_ICMP);

    // catch the echo request
    sock_ret = recvfrom(socket,         
               &echo_request_info,         
               sizeof(echo_request_info), 
               0,       
               NULL,     
               NULL);

    Regards

    Prasanth.

Children
No Data