Post Go back to editing

JTAG ICE-1000 Question

Hi, Everyone.

My problem is the following. There is a PCB with dsp BF-606 and ADC AD7817. I developed a simple code to get temperature from AD7817 and declare a variable to count errors in case if I get 0 or 0xff from adc (assume it adcErr). If adcErr equals 0  or 0xff the LED on PCB goes red. After compiling and loading the code I pressed F5 to start it and everything goes well (LED is green), when I try to check values from AD7817 (press Shift+F5 periodically) randomly data from adc corrupted and LED goes red. What could be the problem? Is it related to ICE-1000 debbuger?

Thanks.

  • Hello,

    I developed a simple code to get temperature from AD7817 and declare a variable to count errors in case if I get 0 or 0xff from adc (assume it adcErr). If adcErr equals 0  or 0xff the LED on PCB goes red. After compiling and loading the code I pressed F5 to start it and everything goes well (LED is green), when I try to check values from AD7817 (press Shift+F5 periodically) randomly data from adc corrupted and LED goes red

    >> In order to narrow down the issue and check if there is any dependency with AD7817, would you please isolate the AD7817 and check if you can reproduce the issue by simply declaring the variable as mentioned above and provide value as 0 or 0xFF.

    Regards,

    Jithul

  • This question has been assumed as answered either offline via email or with a multi-part answer. This question has now been closed out. If you have an inquiry related to this topic please post a new question in the applicable product forum.

    Thank you,
    EZ Admin