ADSP -BF609  Wakeup source issue in hibernate mode

Hello ,

This is regarding "Wakeup source" problem in hibernate Mode:

We are working on Low power modes(Deep sleep &Hibernate) and  running code on
Standalone(From Flash not from Debugger).

Deep sleep is working fine(it is getting wakeup signal).
We are facing issue in wakeup for Hibernate so Please suggest for the same.

our understanding:
After hibernate mode by giving wakeup through port PA_15 i.e wakeup source0
controller shall come out through Dpm event interrupt and it shall restart.


our Query:
For the first time of wakeup signal, it comes out from hibernate and it restarts but
as it is restarting  it shall go to hibernate again and it should wait for wake
up but it is not happening as per our below code. Please help us

Note :the above behaviour is working fine if we configure push button (PE_15 i.e SW10) for wakeup .

please find the attached code which we used for hibernate mode:

Thanks,

Jayapriya

Hibernate.txt.zip
  • 0
    •  Analog Employees 
    on Jun 25, 2013 1:55 AM

    Hi,

    Sorry for the late response.

    As you said the code is working with PE15 but problem occurs with PA15. Can you try to put the PA15 in inactive state before going to hibernate. e.g. if wake up is configured at active high then pull the PA15 low, and then provide the wakeup signal and see if it makes a difference.

    Regards,

    Nabeel

  • 0
    •  Analog Employees 
    on Aug 2, 2018 4:53 PM
    This question has been assumed as answered either offline via email or with a multi-part answer. This question has now been closed out. If you have an inquiry related to this topic please post a new question in the applicable product forum.

    Thank you,
    EZ Admin