EPPI problem

during my work, i use the EPPI2 to receive the image, and use the EPPI0 to display image,that is connect to ch7024.

if i enable one of them alone every times,it work correctly,but if i enable both of them, it works incorrect,  who can help

me, sincere thanks before.

the capture_image_ok.jpg proved that the EPPI2 works correct, but the display is incorrect.

Parents

  • *pREG_SCB5_ARBR0 = 0x0000000;

    *pREG_SCB5_ARBR0 = 0x1000000;

    *pREG_SCB5_ARBR0 = 0x2000000;

    *pREG_SCB5_ARBR0 = 0x3000000;

    *pREG_SCB5_ARBR0 = 0x4000002;

    *pREG_SCB5_ARBR0 = 0x5000002;

    *pREG_SCB5_ARBR0 = 0x6000002;

    *pREG_SCB5_ARBR0 = 0x7000002;

    *pREG_SCB5_ARBR0 = 0xff000007;

        reg_val = *pREG_SCB5_ARBR0;

        *pREG_SCB5_ARBR0 = 0xff000003;

        reg_val = *pREG_SCB5_ARBR0;

    or

    *pREG_SCB5_ARBW0 = 0x0000000;

              *pREG_SCB5_ARBW0 = 0x1000000;

              *pREG_SCB5_ARBW0 = 0x2000000;

              *pREG_SCB5_ARBW0 = 0x3000000;

              *pREG_SCB5_ARBW0 = 0x4000002;

              *pREG_SCB5_ARBW0 = 0x5000002;

              *pREG_SCB5_ARBW0 = 0x6000002;

              *pREG_SCB5_ARBW0 = 0x7000002;

              *pREG_SCB5_ARBR0 = 0xff000007;

        reg_val = *pREG_SCB5_ARBR0;

        *pREG_SCB5_ARBR0 = 0xff000003;

        reg_val = *pREG_SCB5_ARBR0;

    it looks like does not work, thanks

Reply

  • *pREG_SCB5_ARBR0 = 0x0000000;

    *pREG_SCB5_ARBR0 = 0x1000000;

    *pREG_SCB5_ARBR0 = 0x2000000;

    *pREG_SCB5_ARBR0 = 0x3000000;

    *pREG_SCB5_ARBR0 = 0x4000002;

    *pREG_SCB5_ARBR0 = 0x5000002;

    *pREG_SCB5_ARBR0 = 0x6000002;

    *pREG_SCB5_ARBR0 = 0x7000002;

    *pREG_SCB5_ARBR0 = 0xff000007;

        reg_val = *pREG_SCB5_ARBR0;

        *pREG_SCB5_ARBR0 = 0xff000003;

        reg_val = *pREG_SCB5_ARBR0;

    or

    *pREG_SCB5_ARBW0 = 0x0000000;

              *pREG_SCB5_ARBW0 = 0x1000000;

              *pREG_SCB5_ARBW0 = 0x2000000;

              *pREG_SCB5_ARBW0 = 0x3000000;

              *pREG_SCB5_ARBW0 = 0x4000002;

              *pREG_SCB5_ARBW0 = 0x5000002;

              *pREG_SCB5_ARBW0 = 0x6000002;

              *pREG_SCB5_ARBW0 = 0x7000002;

              *pREG_SCB5_ARBR0 = 0xff000007;

        reg_val = *pREG_SCB5_ARBR0;

        *pREG_SCB5_ARBR0 = 0xff000003;

        reg_val = *pREG_SCB5_ARBR0;

    it looks like does not work, thanks

Children
No Data