J-Link LITE won't connect to ADSP-CM408F EZ-KIT Lite

Hello, my name is Zdravko,
Lately i purchased ADSP-CM408F EZ-KIT Lite with J-Link LITE v8.2. After i plugged J-Link for first time,
it asked me for firmware update. Here is the information after the firmware update:
Firmware: J-Link ARM Lite V8 compiled Oct 29 2014 09:03:16
Hardware: V8.00

So, i started IAR Embedded Workbench and tried to debug and download to the processor with JTAG/SWD, but i always get errors. Log files are attached to the post! Is it possible, if J-Link was with some special firmware for this kit and after it updated itself to the newest version to not work?
The processor on the kit is ADSP-CM408 CSWZ-AF, the nearest model that i find in J-Link' s configuration settings is ADSP-CM408 BSWZ-AF. The processor is ok and running with it's demo program, i checked the cable it's ok too. I downloaded the newest software from your site and i get the same error.
I also opened "UM08001_JLink.pdf" user guide and i see that the hardware of J-Link LITE v8.2 doesn't support Cortex-M4 core and maybe i need board with upper hardware version?
Inline image
attachments.zip
  • I solved the problem ... The CM408F Rev H chips have updated security features that can lock out the JTAG!

    Everyone who owns these Rev H chips needs ADSP-CM40x Enablement Package (Rev. 2.1.0) which can be downloaded from here:

    http://www.analog.com/en/design-center/evaluation-hardware-and-software/evaluation-boards-kits/CM40X-EZ.html#eb-relatedsoftware

  • I have entered the download link page but cannot download it,why?

  • Could someone please attach it in the post message?I cannot download it.

  • Can you try erasing the flash? Please go through the User Guide of BSP in doc folder for details.

  •      I've installed the ADSP-CM40x Enablement Package (Rev. 2.1.0)  but still have ' Bad JTAG communication'.error on the ADSP-CM408F EZ-KIT.

    .

      

       Here it is,

    Logging started @ 2016-12-22 07:18
    DLL Compiled: May 5 2015 11:00:52

    Firmware: J-Link ARM Lite V8 compiled Oct 29 2014 09:03:16
    Hardware: V8.00
    S/N: 228209829
    Feature(s): GDB returns O.K. (0272ms, 0272ms total)
    T1184 000:272 JLINK_ExecCommand("ProjectFile = D:\exp2\settings\exp2_Debug.jlink", ...) returns 0x00 (0000ms, 0272ms total)
    T1184 000:272 JLINK_ExecCommand("scriptfile = C:\Program Files (x86)\IAR Systems\Embedded Workbench 7.2\arm\config\debugger\AnalogDevices\CM40z.JLinkScript", ...) returns 0x00 (0000ms, 0272ms total)
    T1184 000:272 JLINK_ExecCommand("device = CM40z_384_2048", ...)Device "ADSP-CM407BSWZ-BF" selected. returns 0x00 (0001ms, 0273ms total)
    T1184 000:273 JLINK_GetDLLVersion() returns 49805 (0000ms, 0273ms total)
    T1184 000:273 JLINK_GetCompileDateTime() (0000ms, 0273ms total)
    T1184 000:273 JLINK_GetFirmwareString(...) (0000ms, 0273ms total)
    T1184 000:273 JLINK_SelectDeviceFamily(14) (0000ms, 0273ms total)
    T1184 000:273 JLINK_SetSpeed(1000) (0002ms, 0275ms total)
    T1184 000:275 JLINK_ExecCommand("SetResetType = 3", ...) returns 0x00 (0000ms, 0275ms total)
    T1184 000:275 JLINK_ExecCommand("SetResetPulseLen = 200", ...) returns 0x14 (0000ms, 0275ms total)
    T1184 000:275 JLINK_SetResetDelay(0) (0000ms, 0275ms total)
    T1184 000:275 JLINK_ResetPullsRESET(ON) (0000ms, 0275ms total)
    T1184 000:275 JLINK_Reset()******************************* J-Link script: Init CM408x ******************************* >0x2B0 JTAG>TotalIRLen = 5, IRPrint = 0x01 >0x30 JTAG> >0x210 JTAG>CM408x (InitTarget): Enabling access to CPU core via TAPC >0x0A JTAG> >0x24 JTAG>CM408x (InitTarget): Sending security key needed for CPU core access >0x0A JTAG> >0x03 JTAG> >0x20 JTAG> >0x20 JTAG> >0x20 JTAG> >0x21 JTAG> >0x01 JTAG> >0x0A JTAG> >0x0C JTAG> >0x0A JTAG> >0x0E JTAG> >0x25 JTAG> >0x2A8 JTAG>
    TotalIRLen = 9, IRPrint = 0x0011 >0x30 JTAG> >0x70 JTAG> >0x40 JTAG> >0x40 JTAG> >0x50 JTAG> >0x40 JTAG> >0x40 JTAG> >0x30 JTAG> >0x40 JTAG> >0x40 JTAG> >0x30 JTAG> >0x40 JTAG> >0x50 JTAG> >0x70 JTAG>
    ***** Error: Bad JTAG communication: Write to IR: Expected 0x1, got 0x0 (TAP Command : 10) @ Off 0x5. (0071ms, 0346ms total)
    T1184 000:275
    ***** Error: Error while identifying Cortex-M device. Wrong AHB ID. Expected 0x04770001, found 0x00000000
    Closed