[#5798] SD/MMC fails to work in latest u-boot 2009.11 on bf548

Document created by Aaronwu Employee on Sep 25, 2013
Version 1Show Document
  • View in full screen mode

[#5798] SD/MMC fails to work in latest u-boot 2009.11 on bf548

Submitted By: Vivi Li

Open Date

2009-12-29 05:07:29     Close Date

2010-03-01 03:14:16

Priority:

Medium High     Assignee:

Cliff Cai

Category:

N/A     Fixed In Release:

N/A

Found In Release:

N/A     Status:

Closed

Board:

N/A     Processor:

BF548

Silicon Revision:

    Resolution:

Fixed

Is the bug repeatable?:

N/A     

Summary: SD/MMC fails to work in latest u-boot 2009.11 on bf548

Details:

 

SD/MMC fails to work in latest u-boot 2009.11 on bf548-ezkit.

SPI MMC works on bf537-stamp.

 

--

U-Boot 2009.11-svn2196 (ADI-2010R1-pre) (Dec 29 2009 - 14:25:33)

 

CPU:   ADSP bf548-0.0 (Detected Rev: 0.2) (parallel flash boot)

Board: ADI BF548 EZ-Kit board

       Support: http://blackfin.uclinux.org/

Clock: VCO: 525 MHz, Core: 525 MHz, System: 131.250 MHz

RAM:   64 MB

Flash: 16 MB

NAND:  256 MiB

MMC:  Blackfin SDH: 0

In:    serial

Out:   serial

Err:   serial

KGDB:  [on serial] ready

Net:   smc911x-0

Hit any key to stop autoboot:  0

bfin>

bfin> mmc rescan 0

sending CMD55 failed

sending CMD3 failed

bfin>

--

 

 

Follow-ups

 

--- Cliff Cai                                                2010-01-19 02:16:21

fixed.

clear every command related flags after sending a command.

 

--- Vivi Li                                                  2010-03-01 03:13:21

OK in trunk now. Close it.

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

No Files Were Found

Attachments

    Outcomes