[#5230] In bf518f-ezbrd u-boot, Ethernet can not work after probe SPI flash

Document created by Aaronwu Employee on Sep 25, 2013
Version 1Show Document
  • View in full screen mode

[#5230] In bf518f-ezbrd u-boot, Ethernet can not work after probe SPI flash

Submitted By: Vivi Li

Open Date

2009-06-11 03:26:57     Close Date

2010-06-09 05:43:10

Priority:

Medium     Assignee:

Mike Frysinger

Category:

N/A     Fixed In Release:

N/A

Found In Release:

2009R1     Status:

Closed

Board:

N/A     Processor:

BF518

Silicon Revision:

    Resolution:

Fixed

Is the bug repeatable?:

N/A     

Summary: In bf518f-ezbrd u-boot, Ethernet can not work after probe SPI flash

Details:

 

In bf518f-ezbrd u-boot, after probe SPI flash, Ethernet can not work. No such problem in other platforms.

 

Bellow is the log:

--

U-Boot 2008.10-svn1905 (ADI-2009R1-rc2) (Jun  8 2009 - 04:40:56)

 

CPU:   ADSP bf518-0.0 (Detected Rev: 0.0) (parallel flash boot)

Board: ADI BF518F EZ-Board board

       Support: http://blackfin.uclinux.org/

Clock: VCO: 400 MHz, Core: 400 MHz, System: 80 MHz

RAM:   64 MB

Flash:  4 MB

In:    serial

Out:   serial

Err:   serial

Net:   Blackfin EMAC

MAC:   00:E0:FE:AA:85:73

Hit any key to stop autoboot:  0

bfin> ping 10.100.4.174

Using Blackfin EMAC device

host 10.100.4.174 is alive

bfin> sf probe 2

SF: Got idcode 20 20 15

2048 KiB M25P16 at 0:2 is now current device

bfin> ping 10.100.4.174

Using Blackfin EMAC device

ping failed; host 10.100.4.174 is not alive

bfin>

--

 

--

U-Boot 2008.10-svn1905 (ADI-2009R1-rc2) (Jun  8 2009 - 04:41:06)

 

CPU:   ADSP bf518-0.0 (Detected Rev: 0.0) (spi flash boot)

Board: ADI BF518F EZ-Board board

       Support: http://blackfin.uclinux.org/

Clock: VCO: 400 MHz, Core: 400 MHz, System: 80 MHz

RAM:   64 MB

Flash:  4 MB

SF: Got idcode 20 20 15

In:    serial

Out:   serial

Err:   serial

Net:   Blackfin EMAC

MAC:   00:E0:FE:AA:85:73

Hit any key to stop autoboot:  0

bfin> ping 10.100.4.174

Using Blackfin EMAC device

host 10.100.4.174 is alive

bfin> sf probe 2

SF: Got idcode 20 20 15

2048 KiB M25P16 at 0:2 is now current device

bfin> ping 10.100.4.174

Using Blackfin EMAC device

ping failed; host 10.100.4.174 is not alive

bfin>

--

 

Follow-ups

 

--- Mike Frysinger                                           2009-06-16 10:41:23

ive added a hack of sorts to the branch to fix the issue so we can move on with

the release.  a proper fix will take a while to formulate.

 

--- Vivi Li                                                  2009-06-23 06:05:02

It's ok on 09r1 branch.

 

--- Mike Frysinger                                           2010-06-02 20:11:40

should be fixed now that drivers are converted to the portmux framework and they

grab their pins whenever they are initialized

 

bfin> t 0 u-boot.bin

Using Blackfin EMAC device

TFTP from server 192.168.1.2; our IP address is 192.168.1.15

Filename 'u-boot.bin'.

Load address: 0x0

Loading: #############

done

Bytes transferred = 180344 (2c078 hex)

bfin> sf probe 31

SF: Detected M25P16 with page size 256, total  2 MB

2048 KiB M25P16 at 0:31 is now current device

bfin> t 0 u-boot.bin

Using Blackfin EMAC device

TFTP from server 192.168.1.2; our IP address is 192.168.1.15

Filename 'u-boot.bin'.

Load address: 0x0

Loading: #############

done

Bytes transferred = 180344 (2c078 hex)

bfin> sf probe 31

SF: Detected M25P16 with page size 256, total  2 MB

2048 KiB M25P16 at 0:31 is now current device

 

--- Vivi Li                                                  2010-06-09 05:40:37

Yes, it works now.

Close this bug.

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

No Files Were Found

Attachments

    Outcomes