[#5156] fail to copy data to some part of parallel flash in bf518-ezbrd

Document created by Aaronwu Employee on Sep 25, 2013
Version 1Show Document
  • View in full screen mode

[#5156] fail to copy data to some part of parallel flash in bf518-ezbrd

Submitted By: Vivi Li

Open Date

2009-05-22 04:32:40     Close Date

2009-05-27 06:00:49

Priority:

Medium     Assignee:

Graf Yang

Category:

N/A     Fixed In Release:

N/A

Found In Release:

2009R1     Status:

Closed

Board:

N/A     Processor:

BF518

Silicon Revision:

    Resolution:

Fixed

Is the bug repeatable?:

N/A     

Summary: fail to copy data to some part of parallel flash in bf518-ezbrd

Details:

 

fail to copy data to some part of parallel flash in bf518-ezbrd in 09r1 branch.

 

--

bfin> protect off 0x20080000 0x203fffff

........................................................ done

Un-Protected 56 sectors

bfin> erase 0x20080000 0x203fffff

 

........................................................ done

Erased 56 sectors

bfin> cp.b 0x1000000 0x20080000 0x320000

Copy to Flash... Flash not Erased

bfin>

--

 

Follow-ups

 

--- Graf Yang                                                2009-05-22 07:39:35

I committed to 200903 and 2009R1 to fix it.

Because of pin conflict, to use the 4th Meg flash, you need to turn off SPI.

 

--- Vivi Li                                                  2009-05-27 06:00:48

u-boot built will fail when SPI is disabled, so I will only the first 3MB nor

flash.

For the test case related to the 4th Meg flash, modify it to use the first 3 MB

flash.

Related test cases are:

protect on/off, copy test in flash.

 

Close this bug now.

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

No Files Were Found

Attachments

    Outcomes