[#5014] nand and its sub command not work

Document created by Aaronwu Employee on Sep 25, 2013
Version 1Show Document
  • View in full screen mode

[#5014] nand and its sub command not work

Submitted By: Graf Yang

Open Date

2009-03-24 22:40:42     Close Date

2009-04-03 07:04:40

Priority:

Medium High     Assignee:

Graf Yang

Category:

N/A     Fixed In Release:

2009R1

Found In Release:

2009R1     Status:

Closed

Board:

EZ-Kit Lite     Processor:

BF548

Silicon Revision:

0.0, 0.1     Resolution:

Fixed

Is the bug repeatable?:

yes     

Summary: nand and its sub command not work

Details:

 

U-Boot 2008.10-svn1715 (ADI-2009R1-pre) (Mar 23 2009 - 10:18:39)               

                                                                               

CPU:   ADSP bf548-0.0 (Detected Rev: 0.0) (nand flash boot)                    

Board: ADI BF548 EZ-Kit board                                                  

       Support: http://blackfin.uclinux.org/                                   

Clock: VCO: 525 MHz, Core: 525 MHz, System: 131.250 MHz                        

RAM:   64 MB                                                                   

Flash: 32 MB                                                                   

NAND:  256 MB

*** Warning - bad CRC or NAND, using default environment                       

                                                                               

In:    serial                                                                  

Out:   serial                                                                  

Err:   serial                                                                  

Net:   Hit any key to stop autoboot:  0                                        

bfin> nand erase clean                                                         

                                                                               

NAND erase: device 0 whole chip                                                

Timeout!                                                                       

NAND 256MiB 3,3V 8-bit: MTD Erase failure: -5                                  

Timeout!                                                                       

NAND 256MiB 3,3V 8-bit: MTD Erase failure: -5                                  

Timeout!

....

 

u-boot 1.1.6 svn1273 and svn1322 are OK,

U-Boot 1.1.6-svn1273 (ADI-2008R1.5) (Jul 21 2008 - 00:35:12)                   

                                                                               

CPU:   ADSP bf548-0.0 (Detected Rev: 0.1)                                      

Board: ADI BF548 EZ-Kit board                                                  

       Support: http://blackfin.uclinux.org/                                   

Clock: VCO: 525 MHz, Core: 525 MHz, System: 131 MHz                            

RAM:   64 MB                                                                   

Flash: 16 MB                                                                   

NAND:  256 MiB                                                                 

In:    serial                                                                  

Out:   serial                                                                  

Err:   serial                                                                  

Net:   LAN9x18 (0x118a0000) detected at 0x24000000                             

MAC:   00:E0:22:FE:B8:54                                                       

Hit any key to stop autoboot:  0                                               

bfin> nand erase clean                                                         

                                                                               

NAND erase: device 0 whole chip                                                

Skipping bad block at  0x00700000                                              

Skipping bad block at  0x089c0000                                              

Skipping bad block at  0x0eea0000                                              

Erasing at 0xffe0000 -- 100% complete. Cleanmarker written at 0xffe0000.       

OK                                                                             

bfin>

 

Follow-ups

 

--- Sonic Zhang                                              2009-03-27 02:51:43

also on bf527

 

--- Graf Yang                                                2009-04-03 02:45:05

Have committed patch about get_timer(), testing on BF526

 

--- Graf Yang                                                2009-04-03 07:04:40

Bug [#5013] 2008.10: bf526-ezbrd "nand erase" command cannot work

is another bug, will be fixing later.

(https://blackfin.uclinux.org/gf/project/u-boot/tracker/?action=TrackerItemEdit&tracker_id=153&tracker_item_id=5013)

 

So this bug is fixed and close.

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

No Files Were Found

Attachments

    Outcomes