[#4681] 1GiB NAND device is only detected as 512MiB

Document created by Aaronwu Employee on Sep 25, 2013
Version 1Show Document
  • View in full screen mode

[#4681] 1GiB NAND device is only detected as 512MiB

Submitted By: Mike Frysinger

Open Date

2008-11-29 23:05:36     Close Date

2008-12-08 17:17:23

Priority:

Medium High     Assignee:

Mike Frysinger

Category:

N/A     Fixed In Release:

N/A

Found In Release:

N/A     Status:

Closed

Board:

N/A     Processor:

N/A

Silicon Revision:

    Resolution:

Rejected

Is the bug repeatable?:

N/A     

Summary: 1GiB NAND device is only detected as 512MiB

Details:

 

in both u-boot and the kernel, a 1GiB NAND device is only detected as 512MiB

 

Follow-ups

 

--- Mike Frysinger                                           2008-12-06 03:29:53

the part in question is M29F8G08DAA ... probably this one:

http://www.micron.com/products/partdetail?part=MT29F8G08DAAWC

 

reading the datasheet, we see this (page 25, table 8):

MT29F4G08AAA  4Gb, x8, 3V  1 1 0 1 1 1 0 0 DCh

MT29F8G08BAA  8Gb, x8, 3V  1 1 0 1 0 0 1 1 D3h

MT29F8G08DAA  8Gb, x8, 3V  1 1 0 1 1 1 0 0 DCh 2

MT29F16G08FAA 16Gb, x8, 3V 1 1 0 1 0 0 1 1 D3h 3

 

and reading the nands_id.c file, we see this:

   {"NAND 512MiB 3,3V 8-bit",  0xDC, 0, 512, 0, LP_OPTIONS},

 

so it makes sense why both the kernel and u-boot are detecting this as 512MiB

rather than 1GiB

 

--- Mike Frysinger                                           2008-12-08 17:17:23

not a bug in the nand stack ...

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

No Files Were Found

Attachments

    Outcomes