[#4342] "reset" failed in u-boot for 561-EZKit/533-EZKit/533-STAMP in trunk

Document created by Aaronwu Employee on Sep 25, 2013
Version 1Show Document
  • View in full screen mode

[#4342] "reset" failed in u-boot for 561-EZKit/533-EZKit/533-STAMP in trunk

Submitted By: Vivi Li

Open Date

2008-08-14 03:35:37     Close Date

2008-09-10 22:15:14

Priority:

Medium High     Assignee:

Mike Frysinger

Category:

N/A     Fixed In Release:

N/A

Found In Release:

N/A     Status:

Closed

Board:

N/A     Processor:

N/A

Silicon Revision:

    Resolution:

Fixed

Is the bug repeatable?:

N/A     

Summary: "reset" failed in u-boot for 561-EZKit/533-EZKit/533-STAMP in trunk

Details:

 

For latest BF561-EZKit/BF533-EZKit/BF533-STAMP in trunk, "reset" command failed to function.

 

Bellow is the log:

--

U-Boot 1.1.6-svn1322 (ADI-2008R2-pre) (Aug 13 2008 - 18:10:40)

 

CPU:   ADSP bf533-0.3 (Detected Rev: 0.5)

Board: ADI BF533 EZ-Kit Lite board

       Support: http://blackfin.uclinux.org/

Clock: VCO: 594 MHz, Core: 594 MHz, System: 118 MHz

RAM:   32 MB

Flash:  2.1 MB

In:    serial

Out:   serial

Err:   serial

Net:   SMC91111 at 0x20310300

MAC:   00:E0:22:FE:BA:29

Hit any key to stop autoboot:  0

bfin>

bfin> res

 

 

U-Boot 1.1.6-svn1322 (ADI-2008R2-pre) (Aug 13 2008 - 18:44:56)

 

CPU:   ADSP bf533-0.3 (Detected Rev: 0.3)

Board: ADI BF533 Stamp board

       Support: http://blackfin.uclinux.org/

Clock: VCO: 398 MHz, Core: 398 MHz, System: 79 MHz

RAM:   128 MB

Flash:  4 MB

In:    serial

Out:   serial

Err:   serial

Net:   SMC91111 at 0x20300300

MAC:   BA:5F:37:C8:87:B3

Hit any key to stop autoboot:  0

bfin>

bfin> res

--

 

Follow-ups

 

--- Mike Frysinger                                           2008-09-08 01:20:51

it would seem that the software reset function triggers a hardware error.  this

hang started happening around svn rev 1295 because that's when i enabled the

hardware error interrupt again.  since we dont disable interrupts anywhere,

ivghw gets triggered and the board hangs since we've reset the system state and

the EVT handlers are in external memory.

 

it would seem that simply doing SWRST = 0x7 causes IVG5 to get latched ...

 

--- Mike Frysinger                                           2008-09-08 02:03:25

ok, it seems that the ADI XML files incorrectly declare SWRST as a 32bit

register.  using the right size seems to fix the issue for me.

 

--- Vivi Li                                                  2008-09-10 22:15:14

OK now. Close it.

Thanks!

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

No Files Were Found

Attachments

    Outcomes