2011-05-30 11:26:27     problem with sd card and fat fs detection on u-boot

Document created by Aaronwu Employee on Sep 25, 2013
Version 1Show Document
  • View in full screen mode

2011-05-30 11:26:27     problem with sd card and fat fs detection on u-boot

Dmitry Romannikov (RUSSIAN FEDERATION)

Message: 100940   

 

Hello!

 

I want to use sd card for uclinux booting but have some problems with it. I've tried to setup sd system based on this docs: http://docs.blackfin.uclinux.org/doku.php?id=bootloaders:u-boot:mmc , so:

 

1. u-boot found mmc card:

 

 

bfin> mmcinit

Using rubico default SPISSEL 4

To change, set environment variable mmc_spi_ssel

to the desired SSEL and run mmcinit again

Currently SSEL 2,3 and 5 doesnt work!

mmc_init failed. retval=0x1

No MMC card found

bfin> setenv mmc_spi_ssel 1

bfin> mmcinit

Using SPISSEL 1

OK! MMC/SD card found.

 

2. u-boot can't detect fat ts:

bfin> fatinfo mmc

** Invalid boot device, use `dev[:part]' **

 

Some additional info:

When I see card's fs on my windows machine i've see that is fat.

u-boot verision is U-Boot 2008.10 (ADI-2009R1-rc3) (Jul 16 2009 - 18:02:12).

 

 

If anybody know how to solve this issue, please help me.

 

Thanks!

QuoteReplyEditDelete

 

 

2011-05-30 12:57:31     Re: problem with sd card and fat fs detection on u-boot

Mike Frysinger (UNITED STATES)

Message: 100943   

 

i think you're just using fatinfo incorrectly.  use something like "0:1" like the error message told you to.

QuoteReplyEditDelete

 

 

2011-05-30 21:31:12     Re: problem with sd card and fat fs detection on u-boot

Dmitry Romannikov (RUSSIAN FEDERATION)

Message: 100948   

 

you are right! after seting dev and partition parts it works! Thanks!

Attachments

    Outcomes