2011-03-11 05:37:10     Problem downloading u-boot to bf516f, timeout.

Document created by Aaronwu Employee on Sep 25, 2013
Version 1Show Document
  • View in full screen mode

2011-03-11 05:37:10     Problem downloading u-boot to bf516f, timeout.

Kent Malmlof (SWEDEN)

Message: 98891   

 

Hi

 

I have built a custom board with a blackfin 516f and are trying to use ldrviewer to download u-boot to the processor. I use a ftdi, usb-uart cable and connect the GND, Tx,Rx and CTS of the cable the the pins on the bf516f. When i try the autobaud it only say timeout, check bmode and reset and try again. I have checked the bmode and it is 3.3v for all the pins (1 1 1 = 7) UART0 bootmode. I have checked the voltage levels to the bf516 and they are correct. i have the usb-uart cable on COM3 and select COM3 in the ldrviewer and have tried different baudrates. The ldr viewer is 1.2 and im trying to download the uart ldr for the bf518 board but should be the same as for the 516f shouldent it? I have also checked the cable with lookrs232 and i seems to work just fine. So what could be the problem??

QuoteReplyEditDelete

 

 

2011-03-11 10:31:18     Re: Problem downloading u-boot to bf516f, timeout.

Mike Frysinger (UNITED STATES)

Message: 98897   

 

i already answered your question in the engineer zone http://ez.analog.com/message/20813#20813

 

if your bmode is definitely 7, then you need to verify the cpu is powering up correctly and the serial is wired correctly.

 

for the first part, simply connect JTAG and read the SYSCR MMR.  if it comes back with bmode set to 7, then that part is sane.

 

for the second part, as the documents on analog.com explain, autobaud is a simple process: write one character (an '@') and read one character.  if you cant do that much, then there's nothing any ldr loader let alone any software like u-boot can do.  you'll need to double check your serial settings, and perhaps find a simple UART test in VDSP that simply echos data it receives so you can load it up via JTAG.

QuoteReplyEditDelete

 

 

2011-03-11 11:51:32     Re: Problem downloading u-boot to bf516f, timeout.

Kent Malmlof (SWEDEN)

Message: 98901   

 

Hi Mike and thx for your answer.

 

Yeah i saw you answer on the engineerzone but thought that it was the wrong forum and made this thread. I am 100% sure that it is bmode 7 becouse all the three pins on the dsp for bmode 0-2 are set on 3.3V which should mean 1 1 1 thats 7, uart0 bmode.

 

What do you mean with powered up? I have checked all the powersupply voltages to the dsp and they are correct set on 3.3, 1.8 and 1.4v on the right pins. I have checked the clock and it is giving me 25MHz clkin. I have checked the cable with lookrs232 and i can send and  recevice by connecting the Tx Rx of the cable so is should work. When i try the ldrviewer and press autobaud nothing happens and i get the error message timeout, check bmode etc... Its like the dsp dosent respond to what is sent to it. I am sure that it reseve @ (0x40) but does not respond to that. What else can be wrong?

QuoteReplyEditDelete

 

 

2011-03-12 01:06:54     Re: Problem downloading u-boot to bf516f, timeout.

Mike Frysinger (UNITED STATES)

Message: 98902   

 

like i said, hook up jtag first

QuoteReplyEditDelete

 

 

2011-03-14 11:09:54     Re: Problem downloading u-boot to bf516f, timeout.

Kent Malmlof (SWEDEN)

Message: 98922   

 

Hi Mike

 

The problem is that i dont have a jtag, i want to use the uboot to load the compiled code to the dsp.

 

But i think i have found a problem, im using a oscillator for the clkin that has a pretty ugly output, dont know why but how importent is it to have a nice wave form for the clkin? the ocsillator that i am using is the epson's sg 310 3.3v 25MHz.

QuoteReplyEditDelete

 

 

2011-03-14 14:42:37     Re: Problem downloading u-boot to bf516f, timeout.

Mike Frysinger (UNITED STATES)

Message: 98926   

 

you cant use u-boot until you know the hardware is sane.  otherwise you waste a lot of time banging on stuff too high up to figure out what the actual problem is lower down.

 

i dont know about the xtal input.  i'm sure the datasheet describes the limits.

QuoteReplyEditDelete

 

 

2011-03-15 04:53:48     Re: Problem downloading u-boot to bf516f, timeout.

Kent Malmlof (SWEDEN)

Message: 98943   

 

Hi Mike

 

Ok i have now ordered a jtag.

 

Still trying to get the oschillator to work correct.

Attachments

    Outcomes