2011-01-26 11:32:55     BF548-EZKIT boot from USB

Document created by Aaronwu Employee on Sep 25, 2013
Version 1Show Document
  • View in full screen mode

2011-01-26 11:32:55     BF548-EZKIT boot from USB

Ulrich Hatje (GERMANY)

Message: 97703   

 

Hi,

 

does anyone know if booting from usb is supposed to work for the bf548-ezkit build of U-boot running on the EZ-Kit? The USB sub-system seems to work in, but "usb start" returns with an USB stick connected:

 

scanning bus for devices... No USB Device found

scanning bus for storage devices... 0 Storage Device(s) found

 

The USB stick does work and can be read after booting a uclinux system (2010-R1) via tftp. We tried several USB devices and before we start debugging, I thought I ask... .

 

We tried both, the 2010-R1-RC2 and the current svn-trunk of U-Boot with the same results.

 

Thanks, Ulrich

QuoteReplyEditDelete

 

 

2011-01-26 11:38:45     Re: BF548-EZKIT boot from USB

Mike Frysinger (UNITED STATES)

Message: 97704   

 

it should be working.  you could also try the 2009R1.1 release.  or set the silicon rev to 0.2 when building and see if that makes a difference (assuming you're booting on a 0.2 cpu).

QuoteReplyEditDelete

 

 

2011-01-26 12:40:54     Re: BF548-EZKIT boot from USB

Ulrich Hatje (GERMANY)

Message: 97706   

 

Hi,

 

setting to 0.2 silicon rev helped.

 

Here a few observations:

 

- usb start only works once after reset (usually no problem)

 

- not all USB sticks work:

 

4 GB stick Corsair Voyagermini:

 

USB:   scanning bus for devices... 1 USB Device(s) found

       scanning bus for storage devices... error in inquiry

0 Storage Device(s) found

 

 

 

4 GB stick Kingston DataTraveler:

 

USB:   scanning bus for devices... 1 USB Device(s) found

       scanning bus for storage devices... 1 Storage Device(s) found

 

 

Older (smaller, <=  2GB) seem to work in most cases.

 

 

 

Thanks a lot for the help!

 

Ulrich

Attachments

    Outcomes