2010-12-21 09:12:12     SPI flash with no signature

Document created by Aaronwu Employee on Sep 25, 2013
Version 1Show Document
  • View in full screen mode

2010-12-21 09:12:12     SPI flash with no signature

Ivan Koryakovskiy (RUSSIAN FEDERATION)

Message: 96913   

 

I am trying to connect by u-boot to M25P80 spi flash. The flash is not made with Technology T9HX which means (according to datasheet) it has no Read Identification instruction ( 0x9F ). Thus it fails with "SF: Unsupported manufacturer FF" error.

 

Note that:

 

U-boot can successfully be booted from M25P80 (I can access flash by additional uC).

 

To probe in U-boot I use "sf probe 2", where CS line is connected to PF2.

 

The Blackfin is BF531

 

 

 

I wonder:

 

1) Does boot ROM uses signature or not (it seems should not)?

 

2) How can I overcome the problem? can I specify directly the flash I use somwhere during u-boot building?

 

Thanks.

QuoteReplyEditDelete

 

 

2010-12-21 10:20:37     Re: SPI flash with no signature

Mike Frysinger (UNITED STATES)

Message: 96916   

 

the bootrom behavior is fully described in the HRM.  it only attempts to do reads.

 

the u-boot 2010R1 release doesnt support non-jedec stmicro flashes, but code was added to trunk for this.

 

also, this is a u-boot question, not linux, so please try to pick the right forum in the future.  ive moved the thread for you.

QuoteReplyEditDelete

 

 

2010-12-22 07:27:18     Re: SPI flash with no signature

Ivan Koryakovskiy (RUSSIAN FEDERATION)

Message: 96949   

 

oh, i was too sleepy yesterday..

 

thanks for answer

Attachments

    Outcomes