2010-10-29 16:18:36     Upgrading U-Boot having trouble

Document created by Aaronwu Employee on Sep 25, 2013
Version 1Show Document
  • View in full screen mode

2010-10-29 16:18:36     Upgrading U-Boot having trouble

Glenn Hart (UNITED STATES)

Message: 95402   

 

I am using U-Boot 1.1.3 and developed for my custom board.  It is very similar to  an BF533 EZ-Kit (SPI EEPROM, SDRAM, SMC91xxx in the same configuration).  I wrote the assembly to transfer U-Boot and the uClinux kernel from the spi eeprom (PF2) to the SDRAM and the stat the linux kernel.  I now want to upgrade to later version of U-Boot and uClinux.  I am having trouble getting U-Boot to work.  I downloaded the 2009 images and burned the ldr file to the eeprom.  I get random character out the serial port.  I also tried the compiling U-Boot 2008 and I get ABCDEFGHIJKLMNOPQRST> out the serial port constantly.  Am I missing something?  It seems the new version of U-Boot should work on my board.

 

 

 

Thanks,

 

Glenn

QuoteReplyEditDelete

 

 

2010-10-31 22:24:13     Re: Upgrading U-Boot having trouble

Aaron Wu (CHINA)

Message: 95425   

 

A little confused, for "new version of u-boot", what's the detailed version, do you mean the u-boot from ADI for BF533 EZ-kit?

QuoteReplyEditDelete

 

 

2010-10-31 22:49:47     Re: Upgrading U-Boot having trouble

Sonic Zhang (CHINA)

Message: 95427   

 

Check your host UART baud configure. The default in uboot is 57600.

QuoteReplyEditDelete

 

 

2010-11-01 09:03:12     Re: Upgrading U-Boot having trouble

Glenn Hart (UNITED STATES)

Message: 95446   

 

I have used 57600 baud for U-boot version 1.1.3 and am using it for 2008/2009.  Same cabling, board, serial program, and settings.

QuoteReplyEditDelete

 

 

2010-11-01 09:11:37     Re: Upgrading U-Boot having trouble

Glenn Hart (UNITED STATES)

Message: 95447   

 

It's been a while since I looked at the EZ-Kit and my custom board.  The difference is going to be in where U-Boot is stored.  The EZ-Kit has the memory mapped flash.  My custom board is using a serial SPI flash.  Does the newer versions of U-Boot (2008 or later) support this.  Version 1.1.3 did not support it and I had to write it myself.

 

 

 

Thanks,

 

Glenn

QuoteReplyEditDelete

 

 

2010-11-01 22:34:33     Re: Upgrading U-Boot having trouble

Aaron Wu (CHINA)

Message: 95455   

 

First please use the latest release, then follow this link to do the SPI Flash flashing: http://docs.blackfin.uclinux.org/doku.php?id=bootloaders:u-boot:serial-flash

 

BTW, can you boot your board successfully from the RAM? I mean tftp load the uImage to DRAM and then execute from DRAM

QuoteReplyEditDelete

 

 

2010-11-08 22:09:07     Re: Upgrading U-Boot having trouble

Mike Frysinger (UNITED STATES)

Message: 95670   

 

the Blackfin u-boot release has long supported booting LDRs out of SPI flashes.  it certainly works for all parts known when 2008R1.5 was released.

 

please review the documentation:

http://docs.blackfin.uclinux.org/doku.php?id=bootloaders:u-boot:booting_methods

QuoteReplyEditDelete

Attachments

    Outcomes